Page MenuHomePhabricator

Help panel: Determine what text and links to show in the help panel on KO and CS wikis
Closed, ResolvedPublic

Description

Per task T206717, when an editor opens the help panel to seek help with editing, they should be shown some links to 'top' help pages for new editors.

Goal:
  1. Work with KO and CS ambassadors to determine the top 5 help pages/articles that users should be shown when opening the Help panel on the respective wikis.
  2. Determine what the "main" area should be to search for more help content on the respective wikis (this would ideally be the contents area from the same place as the top 5 links). Using EN as an example, we've used help pages within the Help: namespace.

Event Timeline

RHo created this task.Nov 12 2018, 4:45 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 12 2018, 4:45 PM
MMiller_WMF renamed this task from Editor help pane: Determine what text and links to show in the help pane on KO and CS wikis to Help pane: Determine what text and links to show in the help pane on KO and CS wikis.Nov 13 2018, 10:54 PM
MMiller_WMF assigned this task to Trizek-WMF.

@Trizek-WMF -- could you please take the lead on this? This is about the links in this mockup: https://wikimedia.invisionapp.com/share/XSP2H5Z7ZMY#/screens/330826495

Here is a screenshot:

Are the "basics of editing" suggestions based on the editor used? Add an image or a citation is really different using wikitext editor, visual editor, mobile wikitext editor... I think we should have a way to point to a specific page it it exists, or at least a specific section. So we should have a local configuration page editable by interface admins.

I think some wikis will have to reconsider their help pages. We need to provide a support like we did with the help desk support suggestions.

RHo added a comment.Nov 14 2018, 11:36 AM

That's a good idea if possible to provide different top 5 links depending on editor context! @MMiller - is this something we want to explore for V1?

@Trizek-WMF and I talked about this. We think we should plan for the ability to distinguish between editors and show different links for different editors. If we can't do it in the first version, well trim it back.

@Trizek-WMF @MMiller_WMF could you post a rough draft of the links (just 2 or 3) and contexts (all of the ones you want to target in version 1) you would use for, say, English Wikipedia so I can better understand how we'll want to structure this in the code?

@kostajh has confirmed it is possible to identify the editor used. It is important to have the right page displayed: what's the point of giving a page full of wikitext explanations to a VE user?

Here is a short list of some useful help pages, depending on the editor:

Those links should be community curated since I'm not sure of the relevance of the wikitext ones. @revi has also raised up that need.

(I'm really concerned by those long help pages that gather everything and its opposite at the same time. But like Marshall says: we want to check if people click on links. The question of quality is secondary. For now.)

I'd like to have this finalized before writing any code for it. For now, I'll build support for 5 links per wiki.

I'd like to have this finalized before writing any code for it. For now, I'll build support for 5 links per wiki.

I'm not sure to understand: are those 3 links enough for you to start? Do you need the links on cs ans ko to code?

I'm not sure to understand: are those 3 links enough for you to start? Do you need the links on cs ans ko to code?

I just want to be sure that we are really providing four/five sets of links (20-25 links total) per wiki, before building out that functionality. If I'm reading the spec in T206717 correctly then we should have:

  1. Mobile visual editor: 5 links
  2. Mobile wikitext editor: 5 links
  3. Desktop visual editor: 5 links
  4. Desktop 2017 wikitext editor: 5 links
  5. Desktop 2010 wikitext editor: 5 links

In addition to these links, T206717 suggests that A/B testing the links might be desirable, in which case we could end up with 40-50 links. Before building out the code to support all of this I just want to make sure we need all of this flexibility.

In the process of determining the finalized set of links we want to show, we might realize that we really only need two sets of links (desktop/mobile, or visual/source) rather than 4-5. And if so, that would save us some time in building out the code for the help pane.

Trizek-WMF added a comment.EditedNov 26 2018, 10:54 AM

I think @MMiller_WMF would be the best to reply concerning the flexibility.

Here is the matrix of possible links updated for 5 actions on 5 editors (based on most frequent question on fr.wp and en.wp). It is possible to get the same help page for multiple editors.
Links stand for English Wikipedia, where some Help pages haven't been updated for VE, since this wiki is the last wiki without this editor as a default one.

Desktop 2017 wikitext editorDesktop 2010 wikitext editorDesktop Visual editorMobile Visual editorMobile Wikitext editor
Add an imageHelp:PicturesHelp:PicturesVE/User_guide#Editing_imagesVE/User_guide#Editing_imagesHelp:Pictures
Add a citationHelp:FootnotesHelp:FootnotesVE/User_guide#Adding_a_new_referenceVE/User_guide#Adding_a_new_referenceHelp:Footnotes
Write a Wikipedia article using the right styleManuel of StyleManuel of StyleManuel of StyleManuel of StyleManuel of Style
How to add/edit the infoboxHelp:InfoboxHelp:InfoboxDoesn't exist on en.wpDoesn't exist on en.wpHelp:Infobox
How to add an external linkWikipedia:External_linksWikipedia:External_linksWikipedia:External_linksWikipedia:External_linksWikipedia:External_links
Trizek-WMF raised the priority of this task from Normal to High.EditedNov 26 2018, 6:35 PM

Raising up the priority of the coordination: we need the links from ko and cs this week.

MMiller_WMF renamed this task from Help pane: Determine what text and links to show in the help pane on KO and CS wikis to Help panel: Determine what text and links to show in the help pane on KO and CS wikis.Nov 29 2018, 7:13 PM
MMiller_WMF updated the task description. (Show Details)
MMiller_WMF renamed this task from Help panel: Determine what text and links to show in the help pane on KO and CS wikis to Help panel: Determine what text and links to show in the help panel on KO and CS wikis.

@Trizek-WMF -- in the matrix you made, it looks like (at least in English Wikipedia), there is not separate help content for wikitext2010 and wikitext2017. It also looks like there is not separate help content for desktop and mobile. Is that right? In that case, perhaps we don't need to have so many columns in the matrix -- just one for wikitext and one for VE. Unless you think there is separate help content for wikitext2010/wikitext2017 and for mobile/desktop in Czech and Korean? I also noticed that Czech and Korean both default to wikitext2010 anyway.

@Trizek-WMF -- in the matrix you made, it looks like (at least in English Wikipedia), there is not separate help content for wikitext2010 and wikitext2017. It also looks like there is not separate help content for desktop and mobile. Is that right?

That's right. There is actually no specific resource I'm aware of concerning mobile editing.

In that case, perhaps we don't need to have so many columns in the matrix -- just one for wikitext and one for VE. Unless you think there is separate help content for wikitext2010/wikitext2017 and for mobile/desktop in Czech and Korean?

I'm thinking about a potential future here:

  • about other languages that may have those ressources
  • about pages that may be created because the panel points a lack of documentation

I also noticed that Czech and Korean both default to wikitext2010 anyway.

Like most wikis, there is a great lack of proper documentation since years. VE is missing.
Concerning the central documentation for VE, https://www.mediawiki.org/wiki/Help:VisualEditor/User_guide/cs is 94% translated; https://www.mediawiki.org/wiki/Help:VisualEditor/User_guide/ko is only 32%.

Thanks, @Trizek-WMF.

So @kostajh, taking this all together, it sounds like in the near term, we don't actually have the diversity and specificity of help pages to fill out a 5x5 matrix. But we theoretically WANT to have that one day. Currently, it seems like a given wiki really could do a 2x5 matrix. So I guess it can be up to you how to engineer it to balance the near term with the long term. Does that help?

Trizek-WMF lowered the priority of this task from High to Normal.Dec 11 2018, 3:58 PM

We have the initial set of links from both KO and CS Wikipedias. This task is remaining open because those communities are still intending to improve the links before the initial launch of the help panel in January.

@MMiller_WMF, @SBisson suggested that we add IDs to each link. I've left a comment about one difficulty with this here https://gerrit.wikimedia.org/r/c/operations/mediawiki-config/+/480106/1/wmf-config/InitialiseSettings.php#21729

Can you please review and let me know what you think?

@kostajh -- @revi updated the links to display in the copy spreadsheet. It looks to me that at least four have been updated to link to newly translated pages on mediawiki.org.

They are for these two rows:

  • hp-wikitext-link-href-2
  • hp-wikitext-link-href-3

And they are the same two new links for both Desktop VE and Mobile VE. That means, however, that there is now one set of links for all three wikitext scenarios (2017, 2010, and mobile) and another set for the two VE scenarios (desktop and mobile). Since we have not yet implemented T211117, we should display the VE set of links.

Does this sound right, @revi?

revi added a comment.Jan 9 2019, 5:47 PM

(Sorry for the delay)

Yes, VE set should be displayed.

@revi @MMiller_WMF could you tell me which ID property to use with the updated links? I can look it up myself too if you don't have time.

Trizek-WMF closed this task as Resolved.Jan 9 2019, 6:56 PM
kostajh reopened this task as Open.Jan 9 2019, 6:57 PM
kostajh claimed this task.
kostajh added a subscriber: Trizek-WMF.

I still need to update two links.

MMiller_WMF added a comment.EditedJan 9 2019, 9:38 PM

@revi -- I was just double checking things, and I noticed that the link you added in cell E34 of the spreadsheet does not match the value in cell E33.

Value in E33: 각주 달기 (footnotes)
Value in E34: https://www.mediawiki.org/wiki/Help:VisualEditor/User_guide/ko#링크_편집하기 (anchors to the section about adding links)

I think the value you meant to put in cell E34 is https://www.mediawiki.org/wiki/Help:VisualEditor/User_guide/ko#각주_편집하기

Is that correct?

kostajh removed kostajh as the assignee of this task.Jan 10 2019, 6:20 PM
Elitre added a subscriber: Elitre.Jan 11 2019, 3:27 PM

(Trizek's part TBE in T213547.)

revi added a comment.Jan 11 2019, 3:52 PM

I think the value you meant to put in cell E34 is https://www.mediawiki.org/wiki/Help:VisualEditor/User_guide/ko#각주_편집하기

Is that correct?

Yes, that's the one. (Note that current prod does not link to MW.org pages at all.)

@kostajh -- now that we have @revi's thoughts, I think we can update the config. I'm not sure how to do it, though, because we now have links to mediawiki.org in there. The correct version is in the spreadsheet under "Desktop VE" and below.

@MMiller_WMF since T209467 has the patch attached, I think we can close this task.

MMiller_WMF closed this task as Resolved.Jan 14 2019, 11:47 PM
MMiller_WMF moved this task from Needs PM Review to Done on the Growth-Team (Current Sprint) board.
MMiller_WMF claimed this task.

Resolving this because we have initial links for both KO and CS in production. Those communities may want to revisit and improve their links, and we can make future tasks for that work.