Page MenuHomePhabricator

Estonian version of "needs-volunteer" tag
Open, Needs TriagePublic

Description

Hi!

We'd like to have a way to show Wikimedia Eesti tasks that need a volunteer, so that we can always have a bunch of stuff interested contributors could pick up and work on, but I suspect using the current Needs-volunteer tag would be inconvenient for non-Estonian users who most often can't do anything about those tasks anyway. Would it be possible to have some sort of "WMEE-needs-volunteer" tag project for this? Or would people rather we used the Needs-volunteer tag anyway? :)

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 13 2018, 12:02 PM

Heh, that's the Wikimedia Commons discussion whether to create lots of very specific categories such as Female Australian writers living in Estonia and speaking Chinese, or to expect folks to search for items which are in all of the categories Female Writer, Australian citizen, Chinese speaker, Estonian resident? :P

What's your use case for patch-welcome? What does "need volunteer" mean, in your interpretation? Also see https://phabricator.wikimedia.org/T194657 ...
Asking because every and any open tasks needs somebody who volunteers to work on that task. In theory.

(Also note that Subprojects at the same level can share tasks, and subprojects on different levels in different subproject hierarchies can share tasks. In case a subproject under WMEE might also be an option.)

Our use case is tasks that are not time critical, but should be available there as something for volunteers to choose from if and when they have time (that is, that we do not prioritize for our team). That said, I guess you do have a point that if something is open and unassigned, that can just be seen as the same as this - in which case, maybe we don't need this after all :D

To me that sounds like setting "Priority" to "lowest"? :P

Fine, we'll try just doing these things for now and come back later if we feel we need anything else :) Feel free to close this for now as whatever seems appropriate.

Aklapper closed this task as Declined.Nov 14 2018, 11:27 PM

Alright, I'll set the status to declined for the time being, but please feel free to set the status back to "Open" via the Add Action...Change Status dropdown if things don't work out. Thanks! :)

tramm reopened this task as Open.EditedTue, Aug 27, 4:34 PM
tramm added a subscriber: tramm.

Just to come back at this... First of all, most of our tasks are not coding tasks. What we are doing now is that we are putting tags on tasks that are explained well enough to be crowdsourced to volunteers without much Wiki-experience (and we publish these super nicely at our Wordpress home page volunteer section). For this we'd need tags like #need-volunteer (which doesn't currently exist, it is mapped to #patch-welcome). But we also plan to sort these tasks into generic #beginner, #intermediate and #advanced tasks.

Currently there are no generic tags for this purpose, so it's not another instance of Wikimedia Commons discussion. What is there and what we could make use of are good first bug patch-welcome Epic Story Microcontribution periodic-update WorkType-Maintenance (and other of this family) Persona-Vandal (and of this family). However we would be mostly misusing them, since they are mostly for code and mostly for specific uses.

We could also create dummy Subprojects of our liking under WMEE and add them not as tags (which is not allowed AFAIK), but subscribers to the tasks (which we can query from Conduit API) — but this would be another dirty hack and misuse of the system.

So, please take your time to rethink if that kind of generic tags of #needs-volunteer and some experience levels could make sense maybe also for other projects (and hackathons — #needs-coder #needs-designer #needs-marketer etc might make sense). Thank you!

tramm added a comment.Tue, Aug 27, 4:43 PM

By the way, I find suggestions of #good-first-task and #mentoring (or maybe #mentoring-available or #mentoring-needed) in T194657 really meaningful. Feel free to change the title of this issue if needed, because it's not about Estonian chapter or language.

Not sure for which exact reasons @Krinkle renamed #Need-volunteer to #patch-welcome. I think I'd prefer to stick to the first phrase.

This would allow to combine a search for #need-volunteer (not limited to code projects) with WMEE project tags ("Swahili" && "female" && "author" tags/categories) instead of creating many fine-grained tags ("Swahili female author" tags/category) that nobody remembers.

#beginner, #intermediate and #advanced

These could either be subprojects, or workboard column names.

#needs-coder #needs-designer #needs-marketer etc might make sense).

I would not want #needs-designer because you can already combine searching for both Design && #need-volunteer on tags etc.

tramm added a comment.Tue, Sep 3, 6:36 PM

Not sure for which exact reasons @Krinkle renamed #Need-volunteer to #patch-welcome. I think I'd prefer to stick to the first phrase.
This would allow to combine a search for #need-volunteer (not limited to code projects) with WMEE project tags ("Swahili" && "female" && "author" tags/categories) instead of creating many fine-grained tags ("Swahili female author" tags/category) that nobody remembers.

Either splitting those two again or sticking to #Need-volunteer would make sense for us too.

#beginner, #intermediate and #advanced

These could either be subprojects, or workboard column names.

I haven't really understood in which circumstances task is allowed to have multiple projects/subprojects/tags/workboard columns and in which circumstances not. If we could add extra workboard column or subproject to any task of its main project, then it would be a reasonable workaround. Any docs you can refer to clear this up for me?

#needs-coder #needs-designer #needs-marketer etc might make sense).

I would not want #needs-designer because you can already combine searching for both Design && #need-volunteer on tags etc.

Sounds reasonable, if there is no standard set of those roles or no plan to additionally promote these roles.

Not sure for which exact reasons @Krinkle renamed #Need-volunteer to #patch-welcome. I think I'd prefer to stick to the first phrase.

I renamed it because I found myself unable to use #Need-volunteer. This phrase sounds dismissive to me and creates separation between what volunteers and staff are expected to work on. Such separation does not make sense to me and and isn't how I want to organise tasks in my backlogs. I've never seen such a tag in other open-source communities. (Especially because they may all be volunteers.) I assumed the tag was inspired by what other open-source communities tend to call patch welcome, used for tasks that are actionable, not yet assigned to anyone, and have consensus for implementation (e.g. from the tech lead or PM).

The phrase #Need-volunteer on the other hand, suggests to me a task is unimportant and may only be accomplished if a volunteer picks it up. (Some teams use Priority-Lowest for that). If this is how the tag was intended, then feel free to rename it back. However, I would then be proposing a new tag to represent the more welcoming intention I described above – as found in other open-source communities.

@Krinkle: Thanks for taking the time to explain. That reasoning makes sense; I agree that it sounded submissive (though #need-volunteer also confuses me as every task requires someone who volunteers to fix that task).

I'm not convinced if volunteer-help-welcome is the best phrase, but for now I'd propose creating that tag and covering in the tag description somehow that this is meant for organizations/chapters to mark tasks that do not require specific access/accounts etc.
(I would not be happy to go down the XYZ-welcomes-volunteer-help road for every XYZ organization we help.)
@reosarevok: Does that sound okay?