Page MenuHomePhabricator

Make wikibase extensions compatible with both version 7.0 & 9.0
Closed, ResolvedPublic5 Story Points

Description

Details

Related Gerrit Patches:
mediawiki/extensions/PropertySuggester : masterAdd compatibility with data model 9.x
mediawiki/extensions/Wikibase : masterAllow installation with DM 9.x
mediawiki/extensions/WikibaseMediaInfo : masterDeclare compatibility with data model 9.x

Event Timeline

Addshore triaged this task as Medium priority.Nov 13 2018, 3:03 PM
Addshore created this task.
Addshore moved this task from incoming to in progress on the Wikidata board.Nov 13 2018, 3:33 PM

Change 472153 had a related patch set uploaded (by Lucas Werkmeister (WMDE); owner: Jeroen De Dauw):
[mediawiki/extensions/Wikibase@master] Allow installation with DM 9.x

https://gerrit.wikimedia.org/r/472153

Change 473545 had a related patch set uploaded (by Lucas Werkmeister (WMDE); owner: Lucas Werkmeister (WMDE)):
[mediawiki/extensions/PropertySuggester@master] Add compatibility with data model 9.x

https://gerrit.wikimedia.org/r/473545

Change 473547 had a related patch set uploaded (by Lucas Werkmeister (WMDE); owner: Lucas Werkmeister (WMDE)):
[mediawiki/extensions/WikibaseMediaInfo@master] Declare compatibility with data model 9.x

https://gerrit.wikimedia.org/r/473547

Change 473547 merged by jenkins-bot:
[mediawiki/extensions/WikibaseMediaInfo@master] Declare compatibility with data model 9.x

https://gerrit.wikimedia.org/r/473547

Change 472153 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] Allow installation with DM 9.x

https://gerrit.wikimedia.org/r/472153

Change 473545 merged by jenkins-bot:
[mediawiki/extensions/PropertySuggester@master] Add compatibility with data model 9.x

https://gerrit.wikimedia.org/r/473545