Page MenuHomePhabricator

Installer fails due to a Call Stack
Closed, ResolvedPublic

Description

Fatal error: Cannot use MediaWiki\Revision\SlotRecord as SlotRecord because the name is already in use in includes\Storage\PageUpdater.php on line 42

Details

Related Gerrit Patches:

Event Timeline

Melos created this task.Nov 13 2018, 9:59 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 13 2018, 9:59 PM

What version of mediawiki are you trying to install?

What version of mediawiki are you trying to install?

master version.
After a manual installation there are other errors while attempting to save like Fatal error: Cannot use MediaWiki\Revision\RevisionSlots as RevisionSlots because the name is already in use in includes\Storage\RevisionSlotsUpdate.php on line 28
I don't know if they came from https://gerrit.wikimedia.org/r/#/c/mediawiki/core/+/461714/

Also REL1_32 branch is affected by the same error.

Can't reproduce with PHP 7.0.31 or HHVM 3.18.6, or in some quick tests with PHP 7.1.20, 7.2.11, or 7.3.0RC4.

@Melos: You'll have to do some debugging of your own to figure out what exactly is going on, as it seems likely this is something specific to your environment.

Melos closed this task as Invalid.Nov 15 2018, 11:38 AM

I have updated my php version from 7.0.10 to 7.0.32 and everything works fine.

Vedmaka reopened this task as Open.Feb 7 2019, 9:05 PM
Vedmaka added a subscriber: Vedmaka.

Also getting same Cannot use MediaWiki\Revision\SlotRecord as SlotRecord because the name is already in use in... error on PHP 7.0.9 when trying to install REL1_32 from git

Anomie added a comment.EditedFeb 7 2019, 9:25 PM

I have updated my php version from 7.0.10 to 7.0.32 and everything works fine.

error on PHP 7.0.9

I looked through https://secure.php.net/ChangeLog-7.php for bugs related to namespace handling, and came across mention of https://bugs.php.net/bug.php?id=66862 which was fixed in PHP 7.0.13. That sounds very much like what is being reported here.

May be we should change the restriction in PHPVersionCheck.php and composer.json?

May be we should change the restriction in PHPVersionCheck.php and composer.json?

Unfortunately not the composer one – we need to keep that at 5.6.99 to maintain HHVM compatibility. But I can bump the PHPVersionCheck one.

Change 490684 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/core@master] Update required PHP version to 7.0.13

https://gerrit.wikimedia.org/r/490684

Change 490688 had a related patch set uploaded (by 20after4; owner: 20after4):
[mediawiki/core@REL1_32] RELEASENOTES: Update required PHP version to 7.0.13

https://gerrit.wikimedia.org/r/490688

Change 490684 merged by jenkins-bot:
[mediawiki/core@master] Update required PHP version to 7.0.13

https://gerrit.wikimedia.org/r/490684

Change 490688 merged by jenkins-bot:
[mediawiki/core@REL1_32] RELEASENOTES: Update required PHP version to 7.0.13

https://gerrit.wikimedia.org/r/490688

Jdforrester-WMF closed this task as Resolved.Feb 14 2019, 9:44 PM
Jdforrester-WMF claimed this task.
Jdforrester-WMF edited projects, added MW-1.32-release; removed Patch-For-Review.

Change 490868 had a related patch set uploaded (by Reedy; owner: Jforrester):
[mediawiki/core@REL1_31] Update required PHP version to 7.0.13

https://gerrit.wikimedia.org/r/490868

Change 490868 merged by jenkins-bot:
[mediawiki/core@REL1_31] Update required PHP version to 7.0.13

https://gerrit.wikimedia.org/r/490868