Page MenuHomePhabricator

Milestone notifications are incorrect
Closed, ResolvedPublic

Description

Hello,

For several days, the milestone notifications ("You just made your _ edit; thank you, _ _ _") have been incorrect. I think that this problem will disturb many newcomers.

When I make my first contribution on a project, I don't receive the notification "You just made your first edit; thank you, and welcome!".
When I make my second contribution on the same project, I receive the notification "You just made your first edit; thank you, and welcome!", linking to my second contribution.
Several days later, when I click again on this notification, it is still opening the article of my second contribution.
There is the same problem with my tenth and eleventh contributions on a project, with the notification "You just made your tenth edit; thank you, and please keep going!".

For instance:

  • On 10 November 2018, in my contributions on no.wiktionary: my first contribution was not notified; my second contribution was about the page "um"; as soon as I did my second contribution, I received the notification "You just made your first edit; thank you, and welcome!" linking to "um".
  • On 11 November 2018, in my contributions on si.wikipedia: same problem, with my first/second contributions.
  • On 11 November 2018, in my contributions on ar.wikipedia: same problem, with my tenth/eleventh contributions.

The milestone notifications have been correct before. For instance:

  • On 24 November 2017, in my contributions on ar.wikipedia, the milestone notification "You just made your first edit; thank you, and welcome!" was correct for my first contribution, about the article "معهد القانون الدولي".
  • On 16 October 2018, in my contributions on fiu-vro.wikipedia, the milestone notification "You just made your first edit; thank you, and welcome!" was correct for my first contribution, about the article "Võro kiil".

Regards

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 14 2018, 9:46 PM
NicoScribe updated the task description. (Show Details)Nov 14 2018, 10:24 PM
Restricted Application added a project: Growth-Team. · View Herald TranscriptNov 15 2018, 2:58 AM

The issue is confirmed in betalabs.

SBisson added a subscriber: SBisson.Dec 4 2018, 2:41 PM

With rMW390fce6db1e0: Move user_editcount updates to a mergeable deferred update edit count is incremented later so when the Echo hook runs, it does not take into account the current edit.

We could consider editCount + 1 for the notification and it would go back to being mostly right.

However, in case of rapid edits, it is possible for the counter to be a few edits behind and there is no guarantee the Echo hook will run for all edit counts values. Therefore it could miss the specific edit counts that trigger notifications. See example below.

  1. 9th edit, edit count property is 8, edit count increment scheduled
  2. 10th edit, edit count is still 8, edit count increment scheduled
  3. 11th edit, edit count is still 8, edit count increment scheduled
  4. Scheduled increments are [merged and] executed, edit count is now 11
SBisson added a subscriber: Catrope.Dec 4 2018, 2:41 PM
JTannerWMF moved this task from Inbox to Upcoming Work on the Growth-Team board.

Change 494257 had a related patch set uploaded (by Sbisson; owner: Sbisson):
[mediawiki/extensions/Echo@master] Fix off-by-one edit count for ThankYouEdit notification

https://gerrit.wikimedia.org/r/494257

SBisson claimed this task.Mar 4 2019, 3:55 PM
SBisson edited projects, added Growth-Team (Current Sprint); removed Growth-Team.
SBisson moved this task from Incoming to Code Review on the Growth-Team (Current Sprint) board.

Change 494257 merged by jenkins-bot:
[mediawiki/extensions/Echo@master] Fix off-by-one edit count for ThankYouEdit notification

https://gerrit.wikimedia.org/r/494257

Etonkovidova closed this task as Resolved.Mar 7 2019, 1:43 AM

Checked the fix in betalabs. Added to the list of fixes to be checked after deployment 1.33.0-wmf.21.