Page MenuHomePhabricator

Cannot create new poll on votewiki
Closed, ResolvedPublic

Description

It is currently (apparently) impossible to create a poll on SecurePoll on votewiki. I am really unsure what I'm doing wrong if anything. It just times out:

Apparently it doesn't matter which settings are used (GPG or no GPG, etc, always fails).

Details

Related Gerrit Patches:
mediawiki/extensions/SecurePoll : masterReplace deprecated SpecialPage::getTitle
mediawiki/extensions/SecurePoll : masterFix undefined property on message by calling the function

Event Timeline

jrbs triaged this task as High priority.Nov 15 2018, 10:49 PM
jrbs created this task.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 15 2018, 10:49 PM
Huji added a comment.Nov 15 2018, 11:01 PM

Someone should look at the server logs and tell us what exactly is logged.

I just used SecurePoll's latest version on my own wiki, and did not have any trouble creating polls.

Huji added a subscriber: Bawolff.Nov 15 2018, 11:02 PM

Brian has been tremendously helpful in situations like this. I am going to add him here, in case he has time to check the server logs.

jrbs renamed this task from Cannot create new poll to Cannot create new poll on votewiki.Nov 15 2018, 11:07 PM
jrbs updated the task description. (Show Details)

Can you include the date and full url accessed? (To narrow it down in log files)

jrbs added a comment.Nov 15 2018, 11:08 PM

I can. Away from laptop for a second but will grab that when I get back.

Forgot to mention a pretty critical part of this task - this is on votewiki.

I don't see anything obvious in logstash logs for votewiki. A bunch of:

Use of SpecialPage::getTitle was deprecated in MediaWiki 1.23. [Called from SecurePoll_ElectionPager::getLinks in /srv/mediawiki/php-1.33.0-wmf.4/extensions/SecurePoll/includes/pages/EntryPage.php at line 166]

and

[W@2OrgpAIC8AABUDc9QAAABU] /wiki/Special:SecurePoll/details/23238   ErrorException from line 108 of /srv/mediawiki/php-1.33.0-wmf.4/extensions/SecurePoll/includes/pages/DetailsPage.php: PHP Notice: Undefined property: Message::$escaped

But those shouldn't cause this type of error.

Does the footer of the error message say anything that might not be captured in the screenshot?

Oh i found some varnish/apache errors:

AH01067: Failed to read FastCGI header (referrer: https://vote.wikimedia.org/wiki/Special:SecurePoll/create)
(104)Connection reset by peer: AH01075: Error dispatching request to :

And then a 503 in the varnish log for JSutherland_(WMF) POST to url /wiki/Special:SecurePoll/create


Which makes it sound like hhvm is segfaulting or something...

jrbs added a comment.Nov 15 2018, 11:52 PM

Does the footer of the error message say anything that might not be captured in the screenshot?

This is the whole screenshot. There's nothing else on the screen at all.

Change 474295 had a related patch set uploaded (by Umherirrender; owner: Umherirrender):
[mediawiki/extensions/SecurePoll@master] Fix undefined property on message by calling the function

https://gerrit.wikimedia.org/r/474295

Change 474299 had a related patch set uploaded (by Umherirrender; owner: Umherirrender):
[mediawiki/extensions/SecurePoll@master] Replace deprecated SpecialPage::getTitle

https://gerrit.wikimedia.org/r/474299

Change 474295 merged by Umherirrender:
[mediawiki/extensions/SecurePoll@master] Fix undefined property on message by calling the function

https://gerrit.wikimedia.org/r/474295

Change 474299 merged by Umherirrender:
[mediawiki/extensions/SecurePoll@master] Replace deprecated SpecialPage::getTitle

https://gerrit.wikimedia.org/r/474299

Those two patches, well good things, probably dont fix whatever is causing fastCGI to explode.

KTC added a subscriber: KTC.Nov 19 2018, 12:11 AM
4nn1l2 added a subscriber: 4nn1l2.Nov 19 2018, 3:13 AM

FTR this is fixed if I force the system to PHP7 via x-Wikimedia-Debug

This is probably also fixed by T209802#4757707 ... is there a way to test without actually creating a new election?

jrbs lowered the priority of this task from High to Medium.Nov 19 2018, 11:53 PM

Lowering since this is proooobably fixed. Hard to reproduce without creating another dummy poll.

Reedy closed this task as Resolved.Fri, Dec 6, 8:04 PM
Reedy claimed this task.
Reedy added a subscriber: Reedy.

FTR this is fixed if I force the system to PHP7 via x-Wikimedia-Debug

PHP7 is everywhere now...