Page MenuHomePhabricator

WikibaseMediaInfo should define keys to ignore when passing test to AbuseFilter
Closed, ResolvedPublic

Description

WikibaseMediaInfo should define array keys of the JSON serialization of MediaInfo entities to be ignored when passing text to EditFilters / Abuse Filters.

https://gerrit.wikimedia.org/r/#/c/mediawiki/extensions/WikibaseMediaInfo/+/474135/ allows configuration of this within the MediaInfo Content object (this was previously hard coded in EntityContent).

This should be done before deploying MediaInfo to commons to avoid having to do something like T205254 as we will have to do for wikidata.org

Tagging Performance as this will improve performance of MediaInfo edits dramatically (as entities get bigger) See T204109#4602542

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 16 2018, 9:34 AM
Addshore updated the task description. (Show Details)
Addshore added a subscriber: Cparle.

This should really be done ASAP.
Otherwise all abusefilters on commons will have to be checked before removing things from the text provided to the filters.

AF is dark magic. What exactly is being exposed now, that we can drop?

Change 483301 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/extensions/WikibaseMediaInfo@master] Set out which entity keys should be ignored for AbuseFilter

https://gerrit.wikimedia.org/r/483301

AF is dark magic.

If you have specific questions you may want to ask @Daimona who's been very active on AF lately and not CC'ed here.

I have alerts for all AF tasks, so I have actually read this, and I'll be glad to help :)

Jdforrester-WMF claimed this task.
Jdforrester-WMF moved this task from To Do to Doing on the SDC Engineering board.
Jdforrester-WMF moved this task from Backlog to Deployment and configuration on the AbuseFilter board.

Change 483301 merged by jenkins-bot:
[mediawiki/extensions/WikibaseMediaInfo@master] Set out which entity keys should be ignored for AbuseFilter

https://gerrit.wikimedia.org/r/483301

This code has been merged. Can @Daimona and/or @Addshore test and confirm it's working as intended?

Cparle closed this task as Resolved.Feb 20 2019, 10:20 AM

Wednesday, February 20th, 2019
10:18 AM — cormacparle_ waves
10:18 AM <cormacparle_ Wanna close this, that ok? https://phabricator.wikimedia.org/T209687
10:18 AM <addshore> *looks*
10:18 AM sounds good to me
10:18 AM <cormacparle_> ace, ta

greg added a project: Multimedia.Mar 7 2019, 10:59 PM