Page MenuHomePhabricator

Redirect from zh-yue.wiktionary.org is not working properly
Closed, ResolvedPublic

Details

Related Gerrit Patches:

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 16 2018, 10:56 AM

There is no rewrite rule for zh-yue wiktionary; there is one for yue wikipedia. See line 97: https://gerrit.wikimedia.org/r/plugins/gitiles/operations/puppet/+/production/modules/mediawiki/files/apache/sites/redirects/redirects.dat

zh-yue wiktionary requests are sent to the incubator main page (https://incubator.wikimedia.org/wiki/Wt/zh-yue?goto=mainpage) which is the source of your problem. That's done somewhere in MediaWiki configs, not by dns or apache redirects. Someone who knows about our setup of https://www.mediawiki.org/wiki/Extension:WikimediaIncubator should look at this. My grep of CommonSettings etc didn't turn up much.

ArielGlenn triaged this task as Medium priority.Nov 16 2018, 11:44 AM
Hydriz added a subscriber: Hydriz.Nov 16 2018, 2:14 PM

The WikimediaIncubator extension is working as intended, as it is supposed to direct users to the main page of the wiki. I think a rewrite rule in redirects.dat should achieve what the reporter originally intended.

Does the community want that, if there is a community of users on the incubator?

Dzahn added a subscriber: Dzahn.Nov 16 2018, 4:32 PM

Yes, renaming of "zh-yue" to "yue" is stalled / lowest since 12 years or more. (2006 before Bugzilla?)

T10217 and T30441

This comment was removed by Urbanecm.

Are there other zh-yue and yue projects that also need to be addressed? I f we are going to add redirects, we might as well do all that are needed.

Dzahn added a comment.EditedNov 16 2018, 8:47 PM

Wikipedia:

zh-classical
zh-min-nan
zh-yue

Wiktionary:

yue
zh
zh-min-nan

Wikiquote:

zh
zh-min-nan

Wikibooks:

zh
zh-min-nan

Wikinews:

zh

Wikisource:

zh
zh-min-nan

Wikivoyage:

zh

Dzahn added a comment.Nov 16 2018, 8:55 PM

re: community desire: T30441#2637271 -> "Many editors of Cantonese Wikipedia have been watching this thread for 9 years"

We just need to add proper redirect rules for zh-yue.wiktionary.org to yue.wiktionary.org at the current stage, period.

ArielGlenn added a comment.EditedNov 19 2018, 1:24 PM

I'm ignoring zh-min-nan for the purposes of this ticket.

One line is just as easy as 5 or 6 when they are all the same sort of redirect for the same language codes.
It looks like the projects that get bounced through the incubator right now are wiktionary, wikinews, wikibooks, wikiquote, wikivoyage. I'll set up a patchset for those.

Nope, this is wrong. We want all the redirects to go from zh-yue to yue... it seems. So why does yue.wikipedia go to zh-yue.wikipedia?

Sorry for seeming to make it more complicated, what I don't want to do is make it *wrong*.

Hello903hello added a comment.EditedNov 20 2018, 10:13 AM

In T209693#4757863, @ArielGlenn wrote:
So why does yue.wikipedia go to zh-yue.wikipedia?

T10217 and T30441
Initially created at zh-yue in 2006, Cantonese Wikipedia didn't have a proper ISO 639-3 code. But soon after that, the code "yue" got approved. However, wiki renaming has been impossible (possible, but problems would arise).

What to do now: Find the mysterious rewrite rule, modify it such that zh-yue.wiktionary.org redirects to yue.wiktionary.org instead of incubator.wikimedia.org/wiki/Wt/zh-yue?goto=mainpage

Ok, I have read all the dang back tckets and thanks everyone for their comments. I am skipping wikisource and betawikiversity because it's more complication than I want to deal with. But here's a changeset that *should* cover everything else so we can not worry about this again, for everything else, except of course the wikipedia rename.

Change 474901 had a related patch set uploaded (by ArielGlenn; owner: ArielGlenn):
[operations/puppet@production] add redirects of various zh-yue projects to yue

https://gerrit.wikimedia.org/r/474901

Needless to say I'd like a bunch of eyes on this to make sure it's right. Thanks in advance.

Change 474901 merged by ArielGlenn:
[operations/puppet@production] add redirects of various zh-yue projects to yue

https://gerrit.wikimedia.org/r/474901

$ curl -D someheaders.txt -H 'X-Wikimedia-Debug: backend=mwdebug1002.eqiad.wmnet' 'https://zh-yue.wiktionary.org/wiki/Page'
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>301 Moved Permanently</title>
</head><body>
<h1>Moved Permanently</h1>
<p>The document has moved <a href="https://yue.wiktionary.org/wiki/Page">here</a>.</p>
</body></html>
$ more someheaders.txt 
HTTP/2 301 
date: Thu, 22 Nov 2018 09:28:27 GMT
content-type: text/html; charset=iso-8859-1
content-length: 244
location: https://yue.wiktionary.org/wiki/Page
server: mwdebug1002.eqiad.wmnet
expires: Sat, 22 Dec 2018 09:28:27 GMT
<snip>

So it looks good to me. This should be live on all production servers in about half an hour.

jcrespo closed this task as Resolved.Nov 28 2018, 3:42 PM
jcrespo assigned this task to ArielGlenn.
jcrespo added a subscriber: jcrespo.

@Hello903hello @Urbanecm this seems to be working after Ariel's patch, resolving. Please reopen if you see issues.