[BUG] Articles loaded from link taps or from search results not appearing in history tab
Open, NormalPublic

Description

How many times were you able to reproduce it?

Every

Steps to reproduce

  1. Clean install
  2. Search for and load Los Angeles article
  3. Return to explore
  4. Tap History icon

Expected results

Should see entry for Los Angeles

Actual results

No Los Angeles entry in History

Environments observed

App version:
develop branch (works in 6.1.1)
OS versions:
iOS 12 (probably 11 too...)
Device model:
All
Device language:
EN (probably all)

Mhurd created this task.Nov 16 2018, 10:10 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 16 2018, 10:10 PM

Upon further testing it seems articles are no longer appearing in history if they are loaded from either search results or article link clicks.

Mhurd updated the task description. (Show Details)Nov 16 2018, 10:25 PM
Mhurd renamed this task from [BUG] `enwiki > los angeles` not appearing in history tab to [BUG] Articles loaded from link taps or from search results not appearing in history tab.
Mhurd added a comment.EditedNov 16 2018, 10:46 PM

suspect regression was introduced here: https://github.com/wikimedia/wikipedia-ios/pull/2768

(edit: initially thought 2770 introduced the regression but now suspect 2c6bf7b (from 2768), which was merged into 2770 but was not part of its changes)

JMinor added a subscriber: JMinor.Nov 19 2018, 7:00 PM

Just tested on 6.1.1 store version (as an update to an existing install) and cannot reproduce this. Is this just for fresh installs?

Still probably worth a 6.1.2 quickie, but just want to clarify scope.

@JMinor broken for all users with explore feed disabled

JMinor triaged this task as Normal priority.Nov 20 2018, 7:19 PM
ABorbaWMF added a subscriber: ABorbaWMF.

Appears to be fixed on 6.2.0 (1549)