Page MenuHomePhabricator

Unable to login to Striker
Closed, ResolvedPublic

Description

I just created a toolforge account connected to my (hopefully future) bot account, DannyS712_bot. After creating the account, I went to log in, but I couldn't. I tried every possible username (DannyS712_bot, DannyS712bot, dannys712_bot, etc) with my password but it just wouldn't work. Is there a way to reset my account? There wasn't a "forgot username or password" button. Please help

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 17 2018, 5:38 PM

Hi @DannyS712, could you please provide exact steps to reproduce, including URLs? Where exactly did you try to log in?
Also see https://wikitech.wikimedia.org/wiki/Help:Getting_Started

I was at https://toolsadmin.wikimedia.org/auth/login/?next=/ and I put in the login I had just created (created at https://toolsadmin.wikimedia.org/register/). It didn't work.
When I tried to make the account again, just in case it hadn't registered, I was told that "Wikimedia account is already in use."

Did you try DannyS712 bot instead of DannyS712_bot, i.e. with the underscore changed to a space?

Krenair renamed this task from Unable to login to toolforge to Unable to login to Striker.Nov 17 2018, 11:06 PM
Krenair added a subscriber: bd808.
krenair@bastion-01:~$ ldapsearch -xLLL "cn=DannyS712 bot" uid cn
dn: uid=dannys712,ou=people,dc=wikimedia,dc=org
cn: DannyS712 bot
uid: dannys712
Framawiki edited projects, added Striker; removed Toolforge.Nov 18 2018, 10:10 AM
Framawiki added subscribers: Danny, Framawiki.
This comment was removed by Framawiki.
Framawiki edited projects, added Toolforge; removed Striker.Nov 18 2018, 10:10 AM
Framawiki removed a subscriber: Danny.
bd808 added a comment.Nov 19 2018, 5:05 PM

There wasn't a "forgot username or password" button.

This is a known issue: T174469: LDAP account that is not attached on wikitech has no means for password reset

I have attached the DannyS712 bot developer account on Wikitech. This will let you use Wikitech's password reset feature to reset the password of your new developer account. I am not currently seeing any sign of repeated failed password attempts in the LDAP directory entry for this account.

DannyS712 closed this task as Resolved.Dec 5 2018, 1:27 AM
DannyS712 claimed this task.

bd808, thanks for attaching the account! There wasn't any sign of repeated failed attempts because, to be honest, I had completely forgotten about the issue. I have logged in, and it works! Thanks