Tracking blocks: Log direction actions
Closed, DeclinedPublic

Description

Actions (edit, rollback , etc.) that are performed directly.
If you attempt to post an edit form and bypass the notice (through a gadget?) or you attempt to perform some other action directly that has no page (like rollback), the block notice page the user gets is not logged.

The Action class will throw a PermissionsError or a UserBlockedError when that happens, it should be tracked (if it is a block that is the cause of the error).

dbarratt created this task.Nov 20 2018, 4:36 PM
dbarratt triaged this task as Low priority.
TBolliger moved this task from Untriaged to Backlog on the Anti-Harassment board.Nov 20 2018, 4:46 PM

Not needed for our Nov. 2018 work.

fdans moved this task from Incoming to Radar on the Analytics board.Dec 3 2018, 5:59 PM
TBolliger closed this task as Declined.Thu, Jan 24, 5:32 PM