Page MenuHomePhabricator

Special:PageAssessments project form field autocomplete ends up in the main search box's autocomplete when using Timeless skin
Closed, ResolvedPublic

Description

The autocomplete for the "project" field is appearing in the place where I'd expect autocomplete for the main search bar to appear. This only appears when I use the Timeless skin, I couldn't reproduce it in Vector.

Event Timeline

Legoktm created this task.Nov 24 2018, 12:27 PM
Restricted Application added a project: Community-Tech. · View Herald TranscriptNov 24 2018, 12:27 PM

Probably just timeless' selectors being too generic.

Okay, so they're both class=suggestions, which is fine, except there are also no ids or anything to distinguish between them. They also appear in the DOM in the exact same place, so... we need to differentiate between the different suggestions somehow. Probably by adding an actual id to the skinnav search, as that's the one that needs the special behaviour (placement, fixed position) but that one is generated as part of core, not the skin, so I'm not really sure how to add it.

ashley added subscribers: matmarex, ashley.

Not just a MediaWiki-extensions-PageAssessments issue but easily reproducible whereever a special page provides a search field to search (e.g. T218565 used Special:PageMigration, a special page provided by MediaWiki-extensions-Translate, and thus available on MediaWiki.org for example for privileged users). This issue is due to Timeless' CSS rules which, as noted in T218565, are needed to fix a different bug; this problematic behavior is also visible on pages where the mediawiki.userSuggest RL module is used to allow to search for a user account (e.g. SocialProfile's Special:GiveGift).

As mentioned in T218565, one major issue is that the div.suggestions elements are created outside the skin's main container element ( div#mw-wrapper), which makes targeting the CSS...difficult, to say the least. cc'ing local JS wizard @matmarex for thoughts on how to best solve this.

Change 500613 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/core@master] jquery.suggestions: Correctly place dropdown for inputs with 'position: fixed'

https://gerrit.wikimedia.org/r/500613

Change 500614 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/skins/Timeless@master] Remove unnecessary workaround for search suggestions dropdown

https://gerrit.wikimedia.org/r/500614

Change 500613 merged by jenkins-bot:
[mediawiki/core@master] jquery.suggestions: Correctly place dropdown for inputs with 'position: fixed'

https://gerrit.wikimedia.org/r/500613

Change 500614 merged by jenkins-bot:
[mediawiki/skins/Timeless@master] Remove unnecessary workaround for search suggestions dropdown

https://gerrit.wikimedia.org/r/500614

matmarex closed this task as Resolved.Apr 23 2019, 6:38 PM
matmarex claimed this task.