Page MenuHomePhabricator

Regression: UI broken in search overlay, image, VE and language overlays
Closed, ResolvedPublic

Description

Searching is suffering from various UI regressions. While usable, there are problems with the spinner showing when it shouldn't and the search in pages feature being squished:

There are similar breakages in the media viewer:
https://en.m.wikipedia.beta.wmflabs.org/wiki/Albert_Einstein#/media/File%3AEinstein_1921_by_F_Schmutzer_-_restoration.jpg

and minor breakages in the languages overlay and visual editor overlay (T210640):

Post morterm

The regressions were due to some problems in the inheritance chain which meant the incorrect class on Overlays was being set. I've documented them in https://gerrit.wikimedia.org/r/#/c/mediawiki/extensions/MobileFrontend/+/476404 Overlays should respect inheritance chain when passing up options

This did not make the train so no SWATs are needed

QA steps

We should visit every single possible overlay in mobile and verify that nothing looks odd about them. Please test this on the BETA CLUSTER
Ideally this should happen after the completion of T209007

The overlays to check are

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 28 2018, 9:19 PM
Jdlrobson triaged this task as Unbreak Now! priority.Nov 28 2018, 9:19 PM

I can replicate on beta cluster and locally

Restricted Application added subscribers: Liuxinyu970226, TerraCodes. · View Herald TranscriptNov 28 2018, 9:19 PM

Change 476397 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/extensions/MobileFrontend@master] Revert "Several View's now pass className and isBorderBox as a property"

https://gerrit.wikimedia.org/r/476397

Jdlrobson renamed this task from Regression: UI broken in search overlay to Regression: UI broken in search overlay, ImageOverlay.Nov 28 2018, 9:37 PM
Jdlrobson updated the task description. (Show Details)
Jdlrobson renamed this task from Regression: UI broken in search overlay, ImageOverlay to Regression: UI broken in search overlay, image and language overlays.
Jdlrobson updated the task description. (Show Details)

Change 476404 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/extensions/MobileFrontend@master] Overlays should respect inheritance chain when passing up options

https://gerrit.wikimedia.org/r/476404

Change 476397 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] Revert "Several View's now pass className and isBorderBox as a property"

https://gerrit.wikimedia.org/r/476397

Change 476404 abandoned by Jdlrobson:
Overlays should respect inheritance chain when passing up options

https://gerrit.wikimedia.org/r/476404

Jdlrobson lowered the priority of this task from Unbreak Now! to Normal.

The regressions were due to some problems in the inheritance chain. I've documented them in https://gerrit.wikimedia.org/r/#/c/mediawiki/extensions/MobileFrontend/+/476404 Overlays should respect inheritance chain when passing up options

This did not make the train so no SWATs are needed.

Change 476426 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/extensions/MobileFrontend@master] Prepare View's for option usage rather than class property

https://gerrit.wikimedia.org/r/476426

Change 476423 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/extensions/MobileFrontend@master] Revert "Revert "Several View's now pass className and isBorderBox as a property""

https://gerrit.wikimedia.org/r/476423

Jdlrobson renamed this task from Regression: UI broken in search overlay, image and language overlays to Regression: UI broken in search overlay, image, VE and language overlays.Nov 29 2018, 5:36 PM
Jdlrobson updated the task description. (Show Details)
Jdlrobson updated the task description. (Show Details)
Jdlrobson added subscribers: Esanders, matmarex.
Jdlrobson updated the task description. (Show Details)
Jdlrobson updated the task description. (Show Details)

Change 476426 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] Prepare View's for option usage rather than class property

https://gerrit.wikimedia.org/r/476426

Change 476423 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] Pass isBorderbox and className properties as options

https://gerrit.wikimedia.org/r/476423

Jdlrobson claimed this task.
Jdlrobson added a subscriber: ABorbaWMF.

I can do generalQA on this as part of my other QA tasks.

Jdlrobson closed this task as Resolved.

Not seeing any problems. Checked all overlays on beta cluster. All display.
While testing I noticed that I'm not seeing any notifications on the beta cluster. Have reached out to a few people to check that is isolated to me or a known issue.