Page MenuHomePhabricator

Create Wikisource Neapolitan
Closed, ResolvedPublic

Description

The language committee has approved the creation of Wikisource Neapolitan.

  • Request page: https://meta.wikimedia.org/wiki/Requests_for_new_languages/Wikisource_Neapolitan
  • Language code: nap
  • Site URL: nap.wikisource.org
  • Project name: Wikisource
  • Project namespace: Wikisource
  • Project talk namespace: Wikisource chiacchiera
  • Project logo: Based on https://commons.wikimedia.org/wiki/File:Wikisource-logo-nap.svg (in reality, it should be the regular Wikisource logo, including the word "Wikisource", but with the graphical element replaced by the .svg file indicated here. Its top resembles Mt. Vesuvius, I am told).
  • Timezone: Europe/Rome
  • Local file uploads: disabled
  • Additional namespaces: "Autore" (Author), "Autore chiàcchiera", "Ennece" (Index), "Ennece chiàcchiera", "Paggena" (Page), "Paggena chiàcchiera", "Opera" (Work), "Opera chiàcchiera"

In addition to the content in the principal body of the test (Category:Napulitano of Multilingual Wikisource) and whatever templates and modules the community designates, there are documents in Categoria:Testi in napoletano of Italian Wikisource that should be copied in as well. (It is unclear at the moment if originals will remain in Italian Wikisource or not.)

Thank you.


Related tasks (not blockers)

Related Objects

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes

For ProofreadPage.aliases I've opened a new task so we can leave the comments in this for the actual wiki creation itself :-)
T210997: Add Neapolitan (nap) translations to ProofreadPage (aliases only)

Ruthven added a comment.EditedDec 7 2018, 7:32 AM

The index and page namespaces are defined in the Proofread Page extension, for which I just submitted a patch above. In addition to this, you can localize the names of the following special pages:

  • Special:IndexPages
  • Special:PagesWithoutScans
  • Special:ProofreadIndexOai
  • Special:ProofreadIndexOaiSchema

(The last two don't seem to be in use on Wikimedia projects.) @Ruthven, if you can provide translations for these I can add them as well. (Oh, and translations don't have to be in AwkwardCamelCase, but can be in Normal spelling.)
The other namespaces (author and work) are defined in wmf-config.

@jhsoby That's the translation. It's up to you to separate the words and use lowercase, or keep the AwkwardCamelCase

Special:IndexPages   --> Speciàle:Paggene Ennece
Special:PagesWithoutScans   --> Speciàle:PaggeneSenzaScan  (e.g. can be Paggene senza scan)
Special:ProofreadIndexOai   --> Speciàle:EnneceLeggiutoOai
Special:ProofreadIndexOaiSchema   --> Speciàle:EnneceLeggiutoSistemaOai
MarcoAurelio added a comment.EditedDec 8 2018, 10:02 PM

Please note, with regards to the Talk namespaces, that the gramatically correct way to write it is posted at T210826#4807547 and is chiàcchiera. We should use that (in consistency as well to what we use already at MessagesNap.php).

MarcoAurelio updated the task description. (Show Details)Dec 8 2018, 10:34 PM

Change 478942 had a related patch set uploaded (by Rafidaslam; owner: Rafid Aslam):
[analytics/refinery@master] Add nap.wikisource to whitelist.tsv

https://gerrit.wikimedia.org/r/478942

Change 478945 had a related patch set uploaded (by Rafidaslam; owner: Rafid Aslam):
[operations/mediawiki-config@master] Add napwikisource

https://gerrit.wikimedia.org/r/478945

@StevenJ81 (or someone from Neapolitan Wikisource), Hi, I wanna ask about what $wgCategoryCollation (https://www.mediawiki.org/wiki/Manual:$wgCategoryCollation) will be used in the wiki. I guess it would be the default one (since Neapolitan Wikipedia uses the default one), but .. I'm kinda not sure, that's why I'm asking here to verify about that

@StevenJ81 (or someone from Neapolitan Wikisource), Hi, I wanna ask about what $wgCategoryCollation (https://www.mediawiki.org/wiki/Manual:$wgCategoryCollation) will be used in the wiki. I guess it would be the default one (since Neapolitan Wikipedia uses the default one), but .. I'm kinda not sure, that's why I'm asking here to verify about that

According to the manual, there are collations specific for each language; nap is not there but I guess the Italian collation should be pretty fine. It would be interesting to know which collation it.wikisource uses.

According to the manual, there are collations specific for each language; nap is not there but I guess the Italian collation should be pretty fine. It would be interesting to know which collation it.wikisource uses.

@Candalua From looking in the InitialiseSettings.php in mediawiki-config repo, itwikisource uses the default one. .. though itwiki uses uca-it-u-kn

@rafidaslam Given that we'll deal with volumes/collections numbering, maybe a numeric sorting will suit the project better.

Collation uca-nap-u-kn would be the best then (if there's no support for nap perhaps you could use uca-it-u-kn or uca-default-u-kn).

Alright, just updated the patch to use uca-it-u-kn for napwikisource's $wgCategoryCollation

Meno25 added a subscriber: Meno25.Dec 26 2018, 10:31 AM

Change 482122 had a related patch set uploaded (by MarcoAurelio; owner: MarcoAurelio):
[mediawiki/services/restbase/deploy@master] Add nap.wikisource

https://gerrit.wikimedia.org/r/482122

Change 482122 merged by Mobrovac:
[mediawiki/services/restbase/deploy@master] vars: Add nap.wikisource

https://gerrit.wikimedia.org/r/482122

Mentioned in SAL (#wikimedia-operations) [2019-01-08T16:00:10Z] <mobrovac@deploy1001> Started deploy [restbase/deploy@503b29c]: Add test-commons and nap.wikisource - T210752 T197616

Mentioned in SAL (#wikimedia-operations) [2019-01-08T17:37:00Z] <mobrovac@deploy1001> Finished deploy [restbase/deploy@503b29c]: Add test-commons and nap.wikisource - T210752 T197616 (duration: 96m 50s)

Change 478942 merged by Milimetric:
[analytics/refinery@master] Add nap.wikisource to whitelist.tsv

https://gerrit.wikimedia.org/r/478942

Urbanecm moved this task from GCI to Blocked on others on the User-Urbanecm board.Mar 24 2019, 9:40 PM
Urbanecm removed rafidaslam as the assignee of this task.Mar 24 2019, 9:42 PM
Urbanecm added a subscriber: rafidaslam.

Unassigning Rafid, nothing left to them.

Given that hywwiki has been created, am I correct to assume that creating napwikisource would also be possible now?

Probably not. Per T212597, there are/were some major problems with the script we use for creating new wikis. It's obviously possible to fix the mess caused by the script, but we prefer to know the root cause of the problems before continuing with any wikis. Ping @Ladsgroup for confirmation, as he discovered those major issues.

There are some complexities that might bite us. I will give this another try on Monday

Xqt changed the status of subtask T212883: Add nap.wikisource to Wikistats from Stalled to Open.Apr 22 2019, 8:06 AM

Note that T212597 was resolved.

There are some complexities that might bite us. I will give this another try on Monday

How went this try?

Dzahn changed the status of subtask T212883: Add nap.wikisource to Wikistats from Open to Stalled.Apr 23 2019, 10:39 PM

There are some complexities that might bite us. I will give this another try on Monday

How went this try?

it bit us.

The issue still exists and it's impossible to make new wikis without lots of bandage and hacks. I'm doing this in volunteer capacity and I don't have time to do it anymore :(

@Ladsgroup That's sad. Do we have a phabricator task filled? If so, could you link it, please? Thanks!

Ruthven added a comment.EditedMay 8 2019, 2:28 PM

Do you mean that it's impossible to create new projects?
In alternative, it's possible to create a project with a working version of Mediawiki? I mean: in the past projects were created (at least in 2003). Why it's not possible to create them in the same way as before, using the same version of the software? (sorry if the question sounds silly)

@Ruthven It's technically possible to create a new project, but workarounding the bug is really time expensive.

By the way, simply rollbacking to previous software version doesn't have to help. The Wikimania infrastructure is rather complex, and the addWiki script has to communicate with a lot of different parts of the infrastructure. The bug can be literally in any part of the infrastructure, and can happen at any time, even with no change of the addWiki script itself.

Rest assured that if there were a simple way how to workaround the bug, we would make use of it ;).

@Ladsgroup That's sad. Do we have a phabricator task filled? If so, could you link it, please? Thanks!

There are several issues at the same time. One is that T212881: addWiki.php broken creating ES tables is still broken (I had it when I made hywwiki) but then re-running with skipping the main cluster causes the text table to point to non-existing value in External Storage and then giving fatal error (I had set things manually in the database to get it back to work). And then once all of this is done, you end up with lots of parts of addWiki.php not being ran so you need to run eval.php and manually run those bits. (Like Cirrus Search indexing, etc.)

My suggestion is to make addWiki.php parts modular, let the runner run each bits of it without much hassle.

@Ladsgroup Thanks for your explanation. Shouldn't we reopen T212881: addWiki.php broken creating ES tables then and/or fill a task for making addWiki.php modular? Theoretically, that would include "just" splitting addWiki's execute method into several other methods (maybe another maintenance scripts for easier running?)

@Ladsgroup Thanks for your explanation. Shouldn't we reopen T212881: addWiki.php broken creating ES tables then and/or fill a task for making addWiki.php modular? Theoretically, that would include "just" splitting addWiki's execute method into several other methods (maybe another maintenance scripts for easier running?)

I would do both

@Ladsgroup Thanks for your explanation. Shouldn't we reopen T212881: addWiki.php broken creating ES tables then and/or fill a task for making addWiki.php modular? Theoretically, that would include "just" splitting addWiki's execute method into several other methods (maybe another maintenance scripts for easier running?)

I would do both

Done.

Dcljr added a subscriber: Dcljr.May 9 2019, 10:51 PM
This comment was removed by Dcljr.
Ankry added a subscriber: Ankry.Jun 2 2019, 9:05 PM

Is there a proposed timeline on this and T218155? Is there information I need to get from the contributor communities to help move this along?

@StevenJ81 Hi, all wiki creations are blocked on T212881. That's a technical problem, and a wiki cannot be technically created.

Thanks for the update, @Urbanecm. Because Western Armenian Wikipedia was created, I thought that had been resolved.

Thank you for asking there if there has been any progress; I've subscribed to that task to make it easier for me to follow.

Change 478945 had a related patch set uploaded (by Reedy; owner: Rafid Aslam):
[operations/mediawiki-config@master] Initial configuration for napwikisource

https://gerrit.wikimedia.org/r/478945

Change 478945 merged by jenkins-bot:
[operations/mediawiki-config@master] Initial configuration for napwikisource

https://gerrit.wikimedia.org/r/478945

Change 530122 had a related patch set uploaded (by Reedy; owner: Reedy):
[operations/mediawiki-config@master] Add napwikisource to wikiversions and commonsupload.dblist

https://gerrit.wikimedia.org/r/530122

Change 530122 merged by jenkins-bot:
[operations/mediawiki-config@master] Add napwikisource to wikiversions and commonsupload.dblist

https://gerrit.wikimedia.org/r/530122

Mentioned in SAL (#wikimedia-operations) [2019-08-14T13:56:34Z] <reedy@deploy1001> Synchronized wmf-config/InitialiseSettings.php: T210752 (duration: 00m 47s)

Mentioned in SAL (#wikimedia-operations) [2019-08-14T13:58:08Z] <reedy@deploy1001> Synchronized static/images/project-logos/: T210752 (duration: 00m 47s)

Reedy closed this task as Resolved.Aug 14 2019, 2:05 PM
Reedy claimed this task.
Reedy changed the status of subtask T212886: Wikidata support for nap.wikisource from Stalled to Open.

Whee, go @Reedy! I can try to import the Neapolitan contents from Wikisource.org at the hackathon tomorrow unless someone else wants to give it a go.

Change 530154 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/services/parsoid@master] lib/config/wmf.sitematrix.json: Update for napwikisource

https://gerrit.wikimedia.org/r/530154

Reedy added a comment.Aug 14 2019, 2:14 PM

Whee, go @Reedy! I can try to import the Neapolitan contents from Wikisource.org at the hackathon tomorrow unless someone else wants to give it a go.

Unfortunately the process is still broken, so I won't be creating any more (unless we get any changes to core/similar to try and fix it) new wikis just now

But we have things documented as the current state of play, so hopefully can make some progress

@jhsoby, @SPQRobin or @MF-Warburg normally handles imports. If you do, remember to import all revisions! :)

Change 530154 merged by jenkins-bot:
[mediawiki/services/parsoid@master] lib/config/wmf.sitematrix.json: Update for napwikisource

https://gerrit.wikimedia.org/r/530154

MarcoAurelio changed the status of subtask T212883: Add nap.wikisource to Wikistats from Stalled to Open.Aug 16 2019, 4:47 PM
Ruthven reopened this task as Open.Sep 3 2019, 12:10 PM

There is a problem with the namespaces. Actually, some names were written in the local language (Neapolitan) instead that in English for the canonical field. This brings some importation errors, and some other general issue.

Examples:

"102": {
     "id": 102,
     "case": "first-letter",
     "subpages": "",
     "canonical": "Autore",
     "*": "Autore"
 },
"103": {
     "id": 103,
     "case": "first-letter",
     "subpages": "",
     "canonical": "Autore chi\u00e0cchiera",
     "*": "Autore chi\u00e0cchiera"
 },

See the full list at: https://nap.wikisource.org/w/api.php?action=query&meta=siteinfo&siprop=namespaces

Ladsgroup closed this task as Resolved.Sep 3 2019, 1:02 PM

The task in question is done, if there are config issues with the new wikis (which usually any new thing has some bugs) please open another ticket and people will fix it. The task of "Create Wikisource Neapolitan" is done here.