Page MenuHomePhabricator

The citation (with template) dialog's Apply changes action is always enabled
Closed, ResolvedPublic

Description

The citation (with template) dialog's Apply changes action is always enabled.

There is some code in ve.ui.MWCitationDialog that tries to handle this, but it doesn't work:

ve.ui.MWCitationDialog has a bunch of weird code calling this.actions.setAbilities() (added in rEVEDda5398909e3b: Don't allow inserting blank citations), which seems to conflict with ve.ui.MWTemplateDialog's setApplicableStatus() calling the same method.
At a glance, I suspect we can remove all of that, and instead override setApplicableStatus() to not allow inserting blank citations.

Event Timeline

matmarex created this task.Nov 29 2018, 9:59 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 29 2018, 9:59 PM

Change 476769 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/Cite@master] ve.ui.MWCitationDialog: Unbreak the logic to enable/disable actions

https://gerrit.wikimedia.org/r/476769

Izno moved this task from Unsorted backlog to External on the Cite board.Dec 8 2018, 12:30 AM

Change 476769 merged by jenkins-bot:
[mediawiki/extensions/Cite@master] ve.ui.MWCitationDialog: Unbreak the logic to enable/disable actions

https://gerrit.wikimedia.org/r/476769

@matmarex: we might have broken something in the process of fixing this :( Reported this regression: T212975

@Ryasmeen Thank you for noticing! Looks like that was caused by another patch, I replied on that task.

Ryasmeen edited projects, added Verified; removed Patch-For-Review.Jan 8 2019, 9:02 PM
Ryasmeen moved this task from QA to Product owner review on the VisualEditor (Current work) board.
JTannerWMF moved this task from Inbox to Low Priority on the Editing QA board.Jan 9 2019, 5:56 PM
matmarex claimed this task.Jan 9 2019, 7:47 PM
marcella closed this task as Resolved.Jan 15 2019, 2:26 PM
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptJan 15 2019, 2:26 PM