Page MenuHomePhabricator

Recent changes limit lowered to 1000
Closed, ResolvedPublic

Description

It seems like the recent changes limit was recently lowered to 1000 (down from 5000). 1000 has been a limit in the select box for a while now, but changing the limit parameter in the URL would work for up to 5000. Since 24 to 48 hours ago, this behavior has changed and I believe wrongly so. I've been relying on that feature for years now, so that I could reach into more distant past in the recent changes. I've noticed this problem on srwiki.

e.g. https://sr.wikipedia.org/w/index.php?limit=1000&title=Special:RecentChanges and https://sr.wikipedia.org/w/index.php?limit=1500&title=Special:RecentChanges return the same list of recent changes (the latter is not longer, as expected)

This might be related to T172026#3483291

Event Timeline

Restricted Application added a project: Growth-Team. · View Herald TranscriptNov 30 2018, 10:57 PM
Restricted Application added subscribers: Petar.petkovic, Aklapper. · View Herald Transcript
Dzahn added a subscriber: Dzahn.Nov 30 2018, 10:57 PM
Kb03 added a subscriber: Kb03.Nov 30 2018, 11:41 PM
kostajh moved this task from Inbox to To Triage on the Growth-Team board.Dec 1 2018, 10:48 PM
NickK awarded a token.Dec 3 2018, 12:00 AM
NickK rescinded a token.
NickK awarded a token.
NickK added a subscriber: NickK.

Is it possible to return it back to 5000? On busy wikis 1000 is not even one day of edits, thus it makes RC patrolling increasingly more difficult. In some cases (e.g. significant number of semi-automated edits) it is just an hour or two of edits, making such small limit barely usable. Thanks

I agree with @NickK that being able to show more than 1000 entries is very handy for RC and CVN work. At the moment I have to use multiple tabs, each with different filters to "break up" the number of entries, since I'm limited to only 1k per tab. Perhaps restoring the previous limit of 5k would be better? If it's a question of users abusing the high limits, maybe limit it to extended confirmed or higher?

@Etonkovidova and @SBisson , could you please have a look at this? Thanks

@NickK The task has been evaluated and will be triaged in the team's incoming meeting next week.

NickK added a comment.Dec 7 2018, 10:18 AM

@NickK The task has been evaluated and will be triaged in the team's incoming meeting next week.

Thanks for this update. Can you please tell us whether any alternative solutions to retrieve more than 1000 edits exist in the meantime (e.g. Query, API etc.)? As this situation seems to last longer (several weeks?), this means that RC patrolling capacity will be seriously affected. Thanks

Are there any updates on this?

Yes, we're going to revert the patch that caused this. It will be in production on the next train. Thanks for your patience!

kostajh claimed this task.Dec 13 2018, 7:22 PM
kostajh edited projects, added Growth-Team (Current Sprint); removed Growth-Team.

Change 479518 had a related patch set uploaded (by Catrope; owner: Kosta Harlan):
[mediawiki/core@master] Revert "ChangesListSpecialPage: Make maximum limit consistent (1000)"

https://gerrit.wikimedia.org/r/479518

Change 479518 merged by jenkins-bot:
[mediawiki/core@master] Revert "ChangesListSpecialPage: Make maximum limit consistent (1000)"

https://gerrit.wikimedia.org/r/479518

Etonkovidova closed this task as Resolved.Dec 14 2018, 11:47 PM

@kostajh - entering more than 1000 for ?limit= in the url will result in self-correcting ?limit=1000 value when RC page is loaded (I do not remember the original behavior for url with ?limit= >1000). Since this task is just reverting the fix, it seems that the original behavior was not displaying in the url values for limit above 1000.

@dungodung
rclimitin API calls is limited to 500 - see, e.g., https://en.wikipedia.org/wiki/Special:ApiSandbox#action=query&format=json&list=recentchanges&rclimit=max

Resolving now, will check in wmf.9.

Before the new RC page (the makeover), the URL didn't used to change when you changed the limit. The limit from the URL was respected up to 5000. Ever since the RC makeover, the URL always displayed up to 1000, but the page did show up to 5000 recent changes (this inconsistency bugged me, but it wasn't a big deal). However, this ticket was raised when the 1000 hard limit was imposed, which I think doesn't make sense for smaller projects.

I see that this has been fixed, i.e. limit of 5000 now works as expected (it still reverts back to 1000 in the URL, but at least it shows 5000 items).