Page MenuHomePhabricator

View 'thwiki_p.page' references invalid table(s) or column(s) or function(s) or definer/invoker of view lack rights to use them
Closed, ResolvedPublic

Description

For some reasons even simple queries like select * from thwiki_p.page limit 10; does not work. Verified through replica under my labs account and quarry: https://quarry.wmflabs.org/query/23037

Event Timeline

Ghuron created this task.Dec 3 2018, 8:55 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 3 2018, 8:55 AM

@Ghuron: Where is the initial place where you found this? :) (I'm wondering which project tag this task should get, so the task will appear on a workboard.)

Ghuron added a comment.Dec 3 2018, 9:01 AM

@Aklapper I've found it in my labs project mw2sparql (it was bgwiki_p initially 07:34 UTC today) but since that I'm repoducing this in quarry (see link above). Sounds like operation issue with db replicas

Zoranzoki21 added a project: Quarry.EditedDec 3 2018, 9:08 AM
Zoranzoki21 added a subscriber: Zoranzoki21.

I can reproduce this problem only for thwiki_p.page: https://quarry.wmflabs.org/query/31779

I tryed with srwiki, it works without problems: https://quarry.wmflabs.org/query/31781

This also happens on zhwiki_p.page.

Ghuron moved this task from Backlog to Wiki replicas on the Data-Services board.Dec 3 2018, 2:04 PM

@Bstorm Mind looking into this? It's affecting some heavily accessed tables like dewiki.page.

Bstorm added a comment.EditedDec 3 2018, 3:58 PM

This is related to T86338
I just have to rebuild those views today.

Bstorm added a comment.Dec 3 2018, 4:05 PM

Done. That should have fixed this.

Ghuron added a comment.Dec 3 2018, 4:17 PM

Fixed for all dbs mentioned above

Ghuron closed this task as Resolved.Dec 3 2018, 4:18 PM

[@Aklapper everything related to replicas/labs db/tools db is related to Data-Services. @Zoranzoki21 like in that case users can support their claims with a Quarry query link, but in most cases the tool is only used to visualize the behavior of labsdbs.]