Page MenuHomePhabricator

Help Panel: Enable on beta labs
Closed, ResolvedPublic

Description

Enable Help Panel on beta labs.

Event Timeline

kostajh created this task.Dec 5 2018, 2:48 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 5 2018, 2:48 PM

Change 477784 had a related patch set uploaded (by Kosta Harlan; owner: Kosta Harlan):
[operations/mediawiki-config@master] Enable Help Panel on beta labs

https://gerrit.wikimedia.org/r/477784

Change 477784 merged by jenkins-bot:
[operations/mediawiki-config@master] Enable Help Panel on beta labs

https://gerrit.wikimedia.org/r/477784

Change 477826 had a related patch set uploaded (by Kosta Harlan; owner: Kosta Harlan):
[operations/mediawiki-config@master] Fix formatting of help panel links

https://gerrit.wikimedia.org/r/477826

Change 477826 merged by jenkins-bot:
[operations/mediawiki-config@master] Fix formatting of help panel links

https://gerrit.wikimedia.org/r/477826

Etonkovidova added a comment.EditedDec 6 2018, 6:11 PM

@RHo (and @kostajh) Do the following minor things need to be fixed?

(1) the transparency issue

(2) the lost part of the message does not appear even when the box is increased:


(3) Why there is a resizing of the text field (as in (2))? In fact, once resized, it's difficult to bring it back to the default position.

(4) The asterisk - does it mean something?

(1) the transparency issue

yes, needs a fix

(2) the lost part of the message does not appear even when the box is increased:

That's the placeholder text. I agree it looks awkward but not sure what can be done with that, other than changing the placeholder text. FWIW, I think the "I need help with editing" is probably redundant or maybe just too vague; would the help desk mentors want to see questions that start with "I need help with editing"?

(3) Why there is a resizing of the text field

I'll see if I can disable resizing.

(4) The asterisk - does it mean something?

yes, it indicates a required field.

Change 478236 had a related patch set uploaded (by Kosta Harlan; owner: Kosta Harlan):
[mediawiki/extensions/GrowthExperiments@master] Help Panel: Fix resizing of textarea

https://gerrit.wikimedia.org/r/478236

Change 478236 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Help Panel: Fix resizing of textarea

https://gerrit.wikimedia.org/r/478236

RHo added a comment.Dec 7 2018, 7:40 PM

(2) the lost part of the message does not appear even when the box is increased:

That's the placeholder text. I agree it looks awkward but not sure what can be done with that, other than changing the placeholder text. FWIW, I think the "I need help with editing" is probably redundant or maybe just too vague; would the help desk mentors want to see questions that start with "I need help with editing"?

  • This is actually the updated placeholder copy after feedback from a number of people about wanting it to be clearer that people should be asking for help about editing by hinting at this using the first sentence, rather than expecting users to re-type in "I need help with editing". Suggest we keep this as is for now and see what help questions look like before further changes.

(3) Why there is a resizing of the text field

I'll see if I can disable resizing.

+1 yes please.

This is actually the updated placeholder copy after feedback from a number of people about wanting it to be clearer that people should be asking for help about editing by hinting at this using the first sentence, rather than expecting users to re-type in "I need help with editing". Suggest we keep this as is for now and see what help questions look like before further changes.

OK, sounds good :)

+1 yes please.

This is done, and is in beta labs now.

Checked the patch for fixing (3).

@kostajh I see a different behavior now for:
(1)

That's the placeholder text. I agree it looks awkward but not sure what can be done with that, other than changing the placeholder

(4) The asterisk - does it mean something?

yes, it indicates a required field.

  • the asterisk is not present until 'Review and submit' is clicked - should we communicate earlier that the input is required?


After the click - notice the asterisk is inside the field and the red outline appears only after the input is deleted. It'd be helpful to display the red outline and the asterisk simultaneously.
Note: the blank input is a valid input.

(2) When 'Include page title with my question' is not clicked, $2 is displayed on Wikipedia:Help desk:

The following probably can be dismissed:

  • (a common issue for IE8) - the field has a horizontal scrolling
kostajh added a comment.EditedDec 9 2018, 10:32 PM

the asterisk is not present until 'Review and submit' is clicked - should we communicate earlier that the input is required?

IIRC this is by design (@RHo please correct me if I'm wrong, because at a quick glance I didn't find the relevant notes in T209318). The idea is that you can click the button on the first step without having entered any text, and you're only required to fill in text on step two. I can easily change it to add the required indicator on step 1 @RHo so just let me know.

After the click - notice the asterisk is inside the field and the red outline appears only after the input is deleted. It'd be helpful to display the red outline and the asterisk simultaneously.

I'll see what can be done about that.

Note: the blank input is a valid input.

You shouldn't be able to submit with empty text, are you saying you were able to?

(2) When 'Include page title with my question' is not clicked, $2 is displayed on Wikipedia:Help desk:

This is going to be changed soon but I'll keep in it in mind.

(a common issue for IE8) - the field has a horizontal scrolling

Not sure what to be done about that, unfortunately; seems like it would have to be fixed in OOUI.

Note: the blank input is a valid input.

You shouldn't be able to submit with empty text, are you saying you were able to?

Yes, the empty post is submitted and looks like the following:

RHo added a comment.Dec 11 2018, 10:22 AM

the asterisk is not present until 'Review and submit' is clicked - should we communicate earlier that the input is required?

IIRC this is by design (@RHo please correct me if I'm wrong, because at a quick glance I didn't find the relevant notes in T209318). The idea is that you can click the button on the first step without having entered any text, and you're only required to fill in text on step two. I can easily change it to add the required indicator on step 1 @RHo so just let me know.

  • hi @kostajh - yes, let's make it mandatory on both steps 1 and 2 please.

Change 478968 had a related patch set uploaded (by Kosta Harlan; owner: Kosta Harlan):
[mediawiki/extensions/GrowthExperiments@master] Help Panel: Make text on step 1 mandatory, fix email handling logic

https://gerrit.wikimedia.org/r/478968

Change 478968 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Help Panel: Make text on step 1 mandatory, fix email handling logic

https://gerrit.wikimedia.org/r/478968

Yes, the empty post is submitted and looks like the following:

@Etonkovidova I can't reproduce this. Could you please file a new issue with steps to reproduce and assign it to me?

yes, let's make it mandatory on both steps 1 and 2 please.

Done. If there's follow up for this, let's put it in a new task please.


I think that's everything but please open up new issues for any bugs, and let's keep this task about enabling Help Panel on beta labs, which I think we can say is done.

After the click - notice the asterisk is inside the field and the red outline appears only after the input is deleted. It'd be helpful to display the red outline and the asterisk simultaneously.

I'll see what can be done about that.

@Etonkovidova I think this is default OOUI behavior. Could we come back to this at a later time if we want to make adjustments?

Etonkovidova closed this task as Resolved.Dec 18 2018, 1:06 AM

Closing the task.

(1) Checked

[mediawiki/extensions/GrowthExperiments@master] Help Panel: Make text on step 1 mandatory, fix email handling logic

https://gerrit.wikimedia.org/r/478968

The mandatory field is outlined in red immediately when the panel is clicked:

(2) The empty input is a valid input - the bug is filed as T212179: [minor] Help panel: White space is a valid input in a question .

(3)

After the click - notice the asterisk is inside the field and the red outline appears only after the input is deleted. It'd be helpful to display the red outline and the asterisk simultaneously.

I'll see what can be done about that.

@Etonkovidova I think this is default OOUI behavior. Could we come back to this at a later time if we want to make adjustments?

Absolutely, it's a minor issue.

Change 482871 had a related patch set uploaded (by Kosta Harlan; owner: Kosta Harlan):
[operations/mediawiki-config@master] GrowthExperiments help panel: Add more example links in beta

https://gerrit.wikimedia.org/r/482871

Change 482871 merged by jenkins-bot:
[operations/mediawiki-config@master] GrowthExperiments help panel: Add more example links in beta

https://gerrit.wikimedia.org/r/482871