Page MenuHomePhabricator

grunt test no runs because of Task "test" not found.
Closed, InvalidPublic

Description

Steps to reproduce

  1. Install dependencies via npm: npm install grunt-banana-checker grunt-eslint grunt-jsonlint grunt-stylelint stylelint stylelint-config-wikimedia
  2. Run grunt test

Expected behaviour
It should run tests and show errors per T210349

Actual behaviour

C:\Users\zoran\Desktop\development\wmf-theme>grunt test
Warning: Task "test" not found. Use --force to continue.

Aborted due to warnings.

C:\Users\zoran\Desktop\development\wmf-theme>

Event Timeline

Shreyasminocha added a subscriber: Shreyasminocha.EditedDec 8 2018, 3:11 PM

Try grunt lint instead. You can always go through a project's Gruntfile.js and see which of the tasks listed towards the end you wish to run.

Edit: Changed suggestion from npm test to grunt lint to be more specific.

Shreyasminocha closed this task as Invalid.Dec 8 2018, 3:14 PM