Page MenuHomePhabricator

Connecting to mwmaint1002 though bast4002 fails
Closed, InvalidPublic

Description

Attempting to ssh mwmaint1002.eqiad.wmnet through bast4002.wikimedia.org results in the error "fork failed: Resource temporarily unavailable", followed by 50-100 lines all reading ssh_exchange_identification: Connection closed by remote host.

This might be some kind of loss of access following the move to the new bastion recently, I'm not sure. The timing matches up though.

My name on prod is foks. The same errors are happening for @Jalexander (not sure what he uses on prod).

(I am really not sure which project this belongs in, so sorry if this is in the wrong place.)

Event Timeline

jrbs created this task.Dec 12 2018, 8:18 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 12 2018, 8:18 AM
jrbs updated the task description. (Show Details)Dec 12 2018, 8:19 AM
jrbs added a subscriber: Jalexander.
Jalexander triaged this task as Unbreak Now! priority.Dec 12 2018, 5:58 PM
Restricted Application added subscribers: Liuxinyu970226, TerraCodes. · View Herald TranscriptDec 12 2018, 5:58 PM

Also hearing that @Thargrovewmf is having issues (she is, like us both, based in the Bay Area so using 4002)

jrbs closed this task as Resolved.Dec 12 2018, 6:07 PM
jrbs claimed this task.

Ahh, this was simple enough. I forgot to change my config's ProxyCommand to match the move from 4001 to 4002. Sorry.

Aklapper changed the task status from Resolved to Invalid.Dec 12 2018, 6:57 PM

(changing task status as no code was changed in a repository / on a server)

Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptDec 12 2018, 6:57 PM