Page MenuHomePhabricator

Invalid HTML when using some math formulas
Closed, ResolvedPublic

Description

Author: almacha

Description:
Found under MediaWiki 1.15

To reproduce:

  1. Make a page with "<math>\int_A</math>" as its only content.
  2. In LocalSettings.php set wgMimeType to "application/xhtml+xml"
  3. Go to the created page.

You get a parse error because an element is not closed, in this piece of code:
"<p><span class="texhtml"></p>"
The problem is the not closed span.


Version: 1.15.x
Severity: normal

Details

Reference
bz19177

Event Timeline

bzimport raised the priority of this task from to Low.Nov 21 2014, 10:41 PM
bzimport added a project: MediaWiki-Parser.
bzimport set Reference to bz19177.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.Jun 12 2009, 8:31 PM

Works for me... I never even get this span in my output, can you clarify?

almacha wrote:

Well, you can look at that page on my wiki, which consists only of the wiki code <math>\int_A</math>:
http://www.almacha.org/achawiki/index.php?title=XHTML_test_fail

IAlex added a comment.Aug 26 2009, 8:02 PM

The problem is not that the span is not closed, but that there is a <p></p> arround it. See the complete source:
<p><span class="texhtml">
</p>

<span style='font-size: x-large; font-family: serif;'>&int;</span>
<i>A</i>

<p></span>
</p>

Could reproduce locally if tidy is disabled.

almacha wrote:

Ok. So is it not a bug because I should use tidy if I want XHTML or is it still a bug because it should nevertheless produce correct XHTML?

IAlex added a comment.Aug 27 2009, 6:33 AM

This is a bug because it should produce correct XHTML. :)

TheDJ set Security to None.

Is this still a problem?

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 16 2015, 3:10 PM
Physikerwelt closed this task as Resolved.Nov 22 2015, 3:05 PM
Physikerwelt claimed this task.