Page MenuHomePhabricator

Enable web font selection for orwiki users
Closed, DeclinedPublic

Description

Odia Wikipedia users are having issue with the fonts while changing devices. The web font selection was helpful before. (
https://www.mediawiki.org/wiki/Universal_Language_Selector/WebFonts#User_preferences.)

Now the option is not showing to change fonts instead show automatically download fonts.

Please shed some light on it or add some fonts for that.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 13 2018, 12:01 PM

We had removed them about an year back and had announced in Tech news https://meta.wikimedia.org/wiki/Tech/News/2017/50

This feature of ULS, in its current form, is in maintanance only status.

That's true. The issue is some of the users are having issue in readability. Like one conjunctions looks different in two different devices.

Do you suggest anything? Or shall we go like that as the issue is not a big problem and may get solved eventually?

santhosh closed this task as Declined.Dec 19 2018, 4:27 AM

The lack of good quality well maintained free licensed fonts, bugs in rendering engines in various operating systems(for example, ନ୍ଦ୍ର has different rendering in Mac) are general issues that goes beyond a single website like wikipedia. We tried to help that situation with webfonts, but it is a costly feature in terms of performance. We can improve that only by investing more resources in wikipedia servers and currently no plans to work on it.

On the otherhand, I recommend to report those issues with operating systems, rendering engines. Also there should be some initiatives to design and develop free licensed well maintained good quality fonts. But this is common for all languages.

Thank You for the information.

I will report the case to respective os provider.