Page MenuHomePhabricator

Enable signature button on meta in main space
Closed, InvalidPublic

Description

When trying to add my signature on meta to endorse a project, I noticed that the signature button is grayed out in VE, so I couldn't add it. I had to switch to wikitext.

Please enable the signature button because it is useful to endorse projects or add support.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 13 2018, 1:08 PM
Esanders added a subscriber: Esanders.EditedDec 13 2018, 9:08 PM

The signature button is only enabled on namespaces marked as "wantSignatures" in MWNamespace.php. This is the same behaviour as WikiEditor. Extra namespaces can be added per-wiki through the $wgExtraSignatureNamespaces config, so if you think one has been missed you can request a specific namespace be added on a specific wiki (see for example T133978 or T195588)

iecetcwcpggwqpgciazwvzpfjpwomjxn renamed this task from Signature button grayed out to Enable signature button on meta in main space.Dec 13 2018, 10:09 PM
This comment was removed by iecetcwcpggwqpgciazwvzpfjpwomjxn.
Rxy added a subscriber: Rxy.Dec 14 2018, 10:59 AM
Framawiki added a subscriber: Framawiki.

Hello @Micru
Even if the requested configuration does not represent a major change, please start discussion somewhere on-wiki to get a consensus.
See https://meta.wikimedia.org/wiki/Requesting_wiki_configuration_changes.

Aklapper reopened this task as Open.Apr 16 2019, 7:44 AM
Aklapper updated the task description. (Show Details)

@Micru: This task is not invalid ("when the problem is not a bug, or when it is a change that is outside the power of the component's developers") until there are specific reasons provided.

Urbanecm closed this task as Invalid.Fri, May 24, 6:43 PM
Urbanecm added a subscriber: Urbanecm.

User is disabled and anyone else is unlikely to provide a community consensus link. Closing as invalid, then.