Page MenuHomePhabricator

ErrorException from line 47 of /srv/mediawiki/php-1.33.0-wmf.8/extensions/Kartographer/includes/ApiQueryMapData.php: PHP Warning: data error
Closed, ResolvedPublic

Description

Noticed in Fatal-Monitor after deploying wmf.8 to all wikis:

[{exception_id}] {exception_url} ErrorException from line 47 of /srv/mediawiki/php-1.33.0-wmf.8/extensions/Kartographer/includes/ApiQueryMapData.php: PHP Warning: data error

Event Timeline

Restricted Application changed the subtype of this task from "Release" to "Task". · View Herald TranscriptDec 13 2018, 2:46 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
zeljkofilipin raised the priority of this task from Normal to Unbreak Now!.Dec 13 2018, 2:46 PM
Restricted Application added subscribers: Liuxinyu970226, Mholloway, TerraCodes. · View Herald TranscriptDec 13 2018, 2:46 PM

Adding to subscribers people that were active in Kartographer since wmf.6: @Umherirrender @MaxSem @Mholloway @Fomafix @matmarex @Yurik @Esanders @Jdforrester-WMF @hoo

Same as T184128, in which the errors were suppressed for the Graph extension but not Kartographer. There's an open patch for this that I'll take another look at and see if it's mergeable.

Change 479455 had a related patch set uploaded (by Mholloway; owner: Mholloway):
[mediawiki/extensions/Kartographer@master] Suppress gzdecode() warning

https://gerrit.wikimedia.org/r/479455

Change 479455 merged by jenkins-bot:
[mediawiki/extensions/Kartographer@master] Suppress gzdecode() warning

https://gerrit.wikimedia.org/r/479455

Change 479475 had a related patch set uploaded (by Jforrester; owner: Mholloway):
[mediawiki/extensions/Kartographer@wmf/1.33.0-wmf.8] Suppress gzdecode() warning

https://gerrit.wikimedia.org/r/479475

Is this resolved?

Is this resolved?

Needs QA when 1.33.0-wmf.9 deploy, at least that's the version the fix is tagged. I will monitor it and post the results here.

Logstash query I will be looking at https://logstash.wikimedia.org/app/kibana#/dashboard/mediawiki-errors?_g=h@8b5b71a&_a=h@6d7142d.

Needs QA when 1.33.0-wmf.9 deploy, at least that's the version the fix is tagged. I will monitor it and post the results here.

wmf.9 is deployed. Please check the logs and resolve the task if the problem is resolved.

Logstash query I will be looking at https://logstash.wikimedia.org/app/kibana#/dashboard/mediawiki-errors?_g=h@8b5b71a&_a=h@6d7142d.

I'm getting Unable to completely restore the URL, be sure to use the share functionality for the above link.

Change 479475 abandoned by Mholloway:
Suppress gzdecode() warning

Reason:
wmf.9 is already rolling out, so I think this is moot at this point.

https://gerrit.wikimedia.org/r/479475

Is this resolved? Train is blocked on moving forward until this is resolved.

Should be resolved after the European Mid-day SWAT coming up shortly.

Mholloway closed this task as Resolved.Dec 19 2018, 12:43 PM
Mholloway claimed this task.

As noted in T211885#4820418 this is not a new issue. The PHP warnings for the underlying issue are now being suppressed as of wmf.9 in ApiQueryMapData.php as was already being done in ApiGraph.php in the Graph extension. I think this can be resolved.

mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:07 PM