Page MenuHomePhabricator

Jade Wireframes: Entity view mode
Closed, DuplicatePublic

Description

Come up with wireframes to show what a Jade page should look like.

The wireframe should:

  • Allow the user to consider (either present directly or via quick links) the entity being considered
  • Allow the user to review the consensus judgments at a glance.
  • Allow the user to review the endorsement and non-consensus judgements
  • Allow the user to perform basic actions:
    • Create a judgment
    • Endorse a judgment
    • Change endorsement
    • Remove endorsement
    • Edit judgment notes
  • Provide basic help text options

Event Timeline

Harej created this task.Dec 19 2018, 11:58 PM
Halfak renamed this task from Jade Wireframes: Entry view mode to Jade Wireframes: Entity view mode.Jan 4 2019, 10:12 PM
Halfak updated the task description. (Show Details)
Harej moved this task from Inbox to In Progress on the Jade board.Jan 7 2019, 9:59 PM
Halfak updated the task description. (Show Details)Jan 9 2019, 5:51 PM
Halfak added a subscriber: Halfak.Jan 11 2019, 6:31 PM

I'm not a designer, but I figured that it would help jump-start our design conversation if I took a stab at some layouts. Below are three wireframes that I have worked out to demonstrate some approaches we might take to generating a nice layout for a entity view. Note that the vertical "..." is intended to represent a menu tab that, when clicked, would display a pop-over menu pane containing options such as "edit", "remove", or "move". I couldn't find any standard way to represent such a thing so I made due.

Tabs

This view is inspired by the tab-based navigation of Special:Preferences. The tabs contain the consensus data. When a tab is selected, the proposals and endorsements are visible. One clear downside to this is that tabs will quickly run out of space horizontally. This can be dealt with by stacking tabs, but that is visually unappealing.

Table

This view was designed to experiment with strategies for mitigating the too-many-tabs problem. The idea is that a table of schemas would be visible. Each row would show the consensus data and some basic stats about the # of proposals/endorsements. When a row is expanded, the proposals and endorsements are visible.

Two Column

This wireframe was developed to explore a mobile compatible entity view. The vector image demonstrates two potential views of an entity. One uses the single-column mobile diff. The other uses a two column default diff view. Each schema is contained within a block that can stack and flow as the browser width changes. The blocks are initially compressed and only show the consensus data but they can be expanded to show reasoning behind the consensus proposal as well as counter-proposals and endorsements.

Halfak reassigned this task from Halfak to Prtksxna.Feb 4 2019, 5:23 PM
Halfak moved this task from Review to Active on the Scoring-platform-team (Current) board.
awight removed a subscriber: awight.Mar 21 2019, 4:05 PM
Halfak removed Prtksxna as the assignee of this task.Apr 1 2019, 4:13 PM
Halfak added a subscriber: Prtksxna.

Moving to backlog because @Prtksxna is unlikely to have time soon.

Harej triaged this task as High priority.Apr 2 2019, 9:19 PM
Harej moved this task from Untriaged to New development on the Scoring-platform-team board.
Halfak moved this task from Active to Review on the Scoring-platform-team (Current) board.
Harej claimed this task.Jun 20 2019, 12:50 AM
Restricted Application added a project: User-Harej. · View Herald TranscriptJun 20 2019, 12:50 AM
Harej moved this task from Inbox to Active Work on the User-Harej board.Jun 20 2019, 12:52 AM
Harej removed Harej as the assignee of this task.Jul 3 2019, 11:38 AM
Harej removed a project: User-Harej.
Harej removed a subscriber: Harej.
Halfak claimed this task.Jul 3 2019, 6:51 PM
Halfak closed this task as a duplicate of T212370: Design Jade entity UI.Aug 6 2019, 8:14 PM
Prtksxna removed a subscriber: Prtksxna.Aug 7 2019, 5:07 AM