Page MenuHomePhabricator

WikiApiary: BumbleBee should stop after 500
Closed, ResolvedPublic

Description

As in T212471: WikiApiary: Getting a 404 on the api.php should stop further requests to the website but this would cover the error HTTP Error 500: Internal Server Error

Event Timeline

I don't think this should be done. A 404 means the website is no longer there, but a 500 could be a temporary error. Maybe reduce the frequency drastically (from 6 hours to 1 week?)

500 is almost always temporary.
There is no reason not to retry in 6 hours, unless the site returned 500 on all past attempts for weeks.

Does BumbleBee only send 1 request to the site? (per run)
If not, 500 should prevent immediate requests (right after receiving 500), because the cause of 500 may be heavy load and last thing they would need are bots.

There can also be a situation when a bug in some extension causes 500 from api.php, but not on the normal site. So administrators of the wiki may not even know that the problem exists (because the wiki itself works).

Note that I just mean that that in that particular run it shouldn't make further requests. Right now, it hits a site several times even if the first one got 500.

I think it may still be worth hitting them 2 or 3 times just in case it is a momentary error. I would consider this more a feature than a bug

I would consider this more a feature than a bug

Yes, any bugs should be fixed first.

DeepBlue closed this task as Resolved.Jan 1 2019, 6:59 PM

400 and 500 errors are handled better now