Page MenuHomePhabricator

Many cawiki users experience VisualEditor getting stuck during loading (due to local script)
Closed, ResolvedPublic

Description

As commented here https://ca.wikipedia.org/wiki/Tema:Uq809uoatujg8ron and https://ca.wikipedia.org/wiki/Tema:Uqgzwa3zib7j4zhc many users are experiencing problems loading VisualEditor interface. Loading seems to get stuck https://commons.wikimedia.org/wiki/File:Problemes_amb_l%27editor_visual.png

Some report that they even experience problems after purging. I'm filling this issue to gather more details and context so it can be reproduced.

Even if purging would solve this problem in some cases (it solved for me, for instance), since it is not a very user-friendly approach, this would need to be handled as well...

Event Timeline

Toniher created this task.Dec 23 2018, 12:26 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 23 2018, 12:26 PM

Can you ask the affected users to open the developer console (F12) while loading the editor, to see if any errors are reported?

Some time ago (one or two weeks) I had similar issues: For me, this was always caused by some request to load.php not finishing loading, e.g. https://de.wikipedia.org/w/load.php?debug=false&lang=de&modules=diffMatchPatch%2Cmoment%2Cpapaparse%2Crangefix%2Cspark-md5%2CtreeDiffer%2Cunicodejs|ext.CodeMirror.data%2Clib%2CvisualEditor|ext.CodeMirror.mode.mediawiki|ext.CodeMirror.visualEditor.init|ext.cite.style%2Cstyles%2CvisualEditor|ext.cite.visualEditor.core%2Cdata%2Cicons|ext.citoid.visualEditor|ext.citoid.visualEditor.data|ext.confirmEdit.visualEditor|ext.disambiguator.visualEditor|ext.geshi.visualEditor|ext.graph.data%2CvisualEditor|ext.kartographer|ext.kartographer.editing%2Cutil%2CvisualEditor|ext.math.styles%2CvisualEditor|ext.math.visualEditor.icons|ext.score.visualEditor|ext.score.visualEditor.icons|ext.templateDataGenerator.editPage|ext.visualEditor.articleTarget%2Cbase%2Ccore%2Cdata%2CdesktopArticleTarget%2CdesktopTarget%2Cdiffing%2Cicons%2Clanguage%2Cmediawiki%2CmoduleIcons%2Cmwalienextension%2Cmwcore%2Cmwextensionmessages%2Cmwextensions%2Cmwformatting%2Cmwgallery%2Cmwimage%2Cmwlanguage%2Cmwlink%2Cmwmeta%2Cmwsave%2Cmwtransclusion%2Cswitching%2Cwelcome|ext.visualEditor.core.desktop|ext.visualEditor.mwextensions.desktop|ext.visualEditor.mwimage.core|ext.wikihiero.visualEditor|jquery.lengthLimit|mediawiki.ForeignStructuredUpload%2CForeignUpload%2CUpload%2Cwidgets|mediawiki.ForeignStructuredUpload.BookletLayout%2Cconfig|mediawiki.Upload.BookletLayout|mediawiki.action.view.redirectPage|mediawiki.language.names|mediawiki.libs.jpegmeta|mediawiki.page.gallery.styles|mediawiki.skinning.content.parsoid|mediawiki.widgets.AbandonEditDialog%2CCategoryMultiselectWidget%2CDateInputWidget%2CMediaSearch%2CStashedFileWidget%2CUserInputWidget|mediawiki.widgets.DateInputWidget.styles|oojs-ui.styles.icons-editing-citation%2Cicons-editing-core%2Cicons-editing-list%2Cicons-editing-styling%2Cicons-layout%2Cicons-location%2Cicons-media%2Cicons-user%2Cicons-wikimedia&skin=vector&version=0yg1szb

But every time I tried to investigate and tried to load the url in a new tab, the url loaded without any problems.

Just occurred again: According to the console the script https://de.wikipedia.org/w/load.php?debug=false&lang=de&modules=diffMatchPatch%2Cmoment%2Coojs-ui%2Coojs-ui-core%2Coojs-ui-toolbars%2Coojs-ui-widgets%2Coojs-ui-windows%2Cpapaparse%2Crangefix%2Cspark-md5%2CtreeDiffer%2Cunicodejs%7Cext.CodeMirror.data%2Clib%2CvisualEditor%7Cext.CodeMirror.mode.mediawiki%7Cext.CodeMirror.visualEditor.init%7Cext.abuseFilter.visualEditor%7Cext.cite.style%2CvisualEditor%7Cext.cite.visualEditor.core%2Cdata%2Cicons%7Cext.citoid.visualEditor%7Cext.citoid.visualEditor.data%7Cext.confirmEdit.visualEditor%7Cext.disambiguator.visualEditor%7Cext.geshi.visualEditor%7Cext.graph.data%2CvisualEditor%7Cext.kartographer%7Cext.kartographer.editing%2Cutil%2CvisualEditor%7Cext.math.styles%2CvisualEditor%7Cext.math.visualEditor.icons%7Cext.score.visualEditor%7Cext.score.visualEditor.icons%7Cext.spamBlacklist.visualEditor%7Cext.templateDataGenerator.editPage%7Cext.titleblacklist.visualEditor%7Cext.visualEditor.articleTarget%2Cbase%2Ccore%2Cdata%2CdesktopArticleTarget%2CdesktopTarget%2Cdiffing%2Cicons%2Clanguage%2Cmediawiki%2CmoduleIcons%2CmoduleIndicators%2Cmwalienextension%2Cmwcore%2Cmwextensionmessages%2Cmwextensions%2Cmwformatting%2Cmwgallery%2Cmwimage%2Cmwlanguage%2Cmwlink%2Cmwmeta%2Cmwsave%2Cmwsignature%2Cmwtransclusion%2Cmwwikitext%2Cswitching%2Cwelcome%7Cext.visualEditor.core.desktop%7Cext.visualEditor.mwextensions.desktop%7Cext.visualEditor.mwimage.core%7Cext.wikihiero.visualEditor%7Cext.wikimediaEvents.visualEditor%7Cjquery.lengthLimit%7Cmediawiki.ForeignStructuredUpload%2CForeignUpload%2CUpload%2Cwidgets%7Cmediawiki.ForeignStructuredUpload.BookletLayout%2Cconfig%7Cmediawiki.Upload.BookletLayout%7Cmediawiki.action.view.redirectPage%7Cmediawiki.diff.styles%7Cmediawiki.language.names%7Cmediawiki.libs.jpegmeta%7Cmediawiki.page.gallery.styles%7Cmediawiki.skinning.content.parsoid%7Cmediawiki.widgets.AbandonEditDialog%2CCategoryMultiselectWidget%2CDateInputWidget%2CMediaSearch%2CStashedFileWidget%2CUserInputWidget%2Cstyles%7Cmediawiki.widgets.DateInputWidget.styles%7Coojs-ui-core.styles%7Coojs-ui.styles.icons-accessibility%2Cicons-alerts%2Cicons-content%2Cicons-editing-advanced%2Cicons-editing-citation%2Cicons-editing-core%2Cicons-editing-list%2Cicons-editing-styling%2Cicons-interactions%2Cicons-layout%2Cicons-location%2Cicons-media%2Cicons-moderation%2Cicons-movement%2Cicons-user%2Cicons-wikimedia%2Cindicators%2Ctextures&skin=vector&version=1pqq9xb failed to load (without any helpful details), trying to load it in a new tab works fine.

Toniher added a subscriber: KRLS.Jan 5 2019, 9:25 PM

One user, @KRLS , reported "TypeError: ve.init.mw.targets is undefined[More information] load.php:15:619" in the console script. There are still many users experiencing this problem.

Some users complain it's already a month they cannot edit. Please, let me know what we can do to move on this. Thanks!

Toniher assigned this task to Qgil.Jan 9 2019, 10:16 PM
Toniher removed Qgil as the assignee of this task.
Toniher added a subscriber: Qgil.
Elitre added a subscriber: Elitre.Jan 10 2019, 4:01 PM

@Toniher, it appears that several people are indeed able to use the visual editor still, so there may be something going on for the others. I see other tasks about loading issues, but in the meantime you may be well positioned to help someone follow https://www.mediawiki.org/wiki/Help:Locating_broken_scripts . "Checklists" like this have been immensely helpful in the past.

Thanks @Elitre , that's a good guide. I'll try to see if I can engage some affected users on this!

It seems so far that the problem is solved. The problem seemed to be an outdated gadget that many people were using https://ca.wikipedia.org/wiki/MediaWiki:Gadget-resumsperdefecte.js (adapted from: https://en.wikipedia.org/wiki/MediaWiki:Gadget-defaultsummaries.js )
Thanks for the great help!

Toniher closed this task as Resolved.Jan 12 2019, 11:29 AM
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptJan 12 2019, 11:29 AM
Qgil awarded a token.Jan 14 2019, 9:28 AM
Aklapper renamed this task from Many cawiki users experience VisualEditor getting stuck during loading to Many cawiki users experience VisualEditor getting stuck during loading (due to local script).Jan 14 2019, 11:28 AM