Page MenuHomePhabricator

Change tags in some interfaces are missing parenthesis
Closed, ResolvedPublic

Description

Original title: Change tags in revision diffs are missing parenthesis

rMW1a5b26f0b604: Changelist "tags" item is wrapped in brackets via CSS

Screenshot from https://en.wikipedia.org/w/index.php?title=Rose_Nylund&curid=2935098&diff=875340192&oldid=868648183&diffmode=source&uselang=en

Seems that the stylesheet is not loaded on diffs.

QA steps

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 25 2018, 7:23 PM

Change 481935 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/core@master] Tag markers should be wrapped in parentheses on diff page

https://gerrit.wikimedia.org/r/481935

Change 481935 merged by jenkins-bot:
[mediawiki/core@master] Tag markers should be wrapped in parentheses on diff page

https://gerrit.wikimedia.org/r/481935

Jdlrobson closed this task as Resolved.Jan 2 2019, 9:00 PM
Jdlrobson claimed this task.

Thanks @Volker_E for the merg! This is now fixed on master. On its way to production via the deployment schedule.

There's the same problem on Special:Log and also in other interfaces, like action=editchangetags, action=historysubmit or action=revisiondelete. I don't think this list is complete...

Jdlrobson reopened this task as Open.Jan 3 2019, 8:44 PM

Hmm... how can I get a comprehensive list? I'll take a look at this tomorrow.

Thank you. Callers of ChangeTags::formatSummaryRow should be a good start.

matej_suchanek renamed this task from Change tags in revision diffs are missing parenthesis to Change tags in some interfaces are missing parenthesis.Jan 3 2019, 8:52 PM
matej_suchanek removed a project: Patch-For-Review.
matej_suchanek updated the task description. (Show Details)

Sorry about this. If an urgent fix is needed I suggest using MediaWiki:Common.css in the meantime. I'm still trying to work out the best way to do this as there is no shared CSS module between these pages. It may make sense to generalise the CSS rule - either a css file loaded on all special pages or mediawiki.skinning.interface.

@Fomafix @Volker_E what if we put this in mediawiki.skinning.interface .. are brackets useful in non-special pages?

Change 483042 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/core@master] Apply the mw-tag-markers rule to all special pages

https://gerrit.wikimedia.org/r/483042

Change 483042 merged by jenkins-bot:
[mediawiki/core@master] Apply the pseudo-css selector rules to diff and changelist pages

https://gerrit.wikimedia.org/r/483042

Jdlrobson closed this task as Resolved.Feb 27 2019, 6:42 PM

On Thursday this should be fixed on all wikis.
Please test this out on mediawiki.org and let me know if this is broken anywhere!

Special:Log seems completely omitted from the fix.

Jdlrobson reopened this task as Open.Feb 27 2019, 8:10 PM
Jdlrobson removed a project: Patch-For-Review.
Jdlrobson updated the task description. (Show Details)
Jdlrobson updated the task description. (Show Details)Feb 27 2019, 8:13 PM

Looks like something went wrong in the rebase... my apologies for declaring this resolved prematurely.

Jdlrobson moved this task from Inbox to Next up on the User-Jdlrobson board.Feb 28 2019, 9:04 PM

Change 493513 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/core@master] Add mediawiki.interface.helpers.styles where it is needed

https://gerrit.wikimedia.org/r/493513

Change 493513 merged by jenkins-bot:
[mediawiki/core@master] Add mediawiki.interface.helpers.styles where it is needed

https://gerrit.wikimedia.org/r/493513

This is now live on beta cluster. The code for using these tags is not very well organised so it's possible I've missed a few. Any testing experienced editors can provide with be most helpful, however I can confirm all the ones listed in task description are now working...

matej_suchanek closed this task as Resolved.Mar 19 2019, 4:31 PM
matej_suchanek removed a project: Patch-For-Review.

Change 500821 had a related patch set uploaded (by Matěj Suchánek; owner: Matěj Suchánek):
[mediawiki/core@master] Style change tags correctly on log extracts

https://gerrit.wikimedia.org/r/500821

Change 500821 merged by jenkins-bot:
[mediawiki/core@master] Style change tags correctly on log extracts

https://gerrit.wikimedia.org/r/500821

Change 517912 had a related patch set uploaded (by Matěj Suchánek; owner: Matěj Suchánek):
[mediawiki/core@master] Style change tags correctly on Special:Newpages

https://gerrit.wikimedia.org/r/517912

Change 517913 had a related patch set uploaded (by Matěj Suchánek; owner: Matěj Suchánek):
[mediawiki/core@REL1_33] Style change tags correctly on Special:Newpages

https://gerrit.wikimedia.org/r/517913

Change 517912 merged by jenkins-bot:
[mediawiki/core@master] Style change tags correctly on Special:Newpages

https://gerrit.wikimedia.org/r/517912

Change 517913 merged by jenkins-bot:
[mediawiki/core@REL1_33] Style change tags correctly on Special:Newpages

https://gerrit.wikimedia.org/r/517913