Page MenuHomePhabricator

JavaScript error on Q42 (Douglas Adams) item
Closed, ResolvedPublic

Description

On https://www.wikidata.org/wiki/Q42, I get:

jQuery.Deferred exception: this is undefined SELF.prototype._buildReport@https://www.wikidata.org/w/extensions/WikibaseQualityConstraints/modules/gadget.js?63f1d:285:33
SELF.prototype._addResultsToSnak@https://www.wikidata.org/w/extensions/WikibaseQualityConstraints/modules/gadget.js?63f1d:434:17
SELF.prototype._addReportsToStatement@https://www.wikidata.org/w/extensions/WikibaseQualityConstraints/modules/gadget.js?63f1d:495:18
SELF.prototype._renderWbcheckconstraintsResult/<@https://www.wikidata.org/w/extensions/WikibaseQualityConstraints/modules/gadget.js?63f1d:117:6
each@https://www.wikidata.org/w/resources/lib/jquery/jquery.js?6a07d:354:10
each@https://www.wikidata.org/w/resources/lib/jquery/jquery.js?6a07d:189:10
SELF.prototype._renderWbcheckconstraintsResult@https://www.wikidata.org/w/extensions/WikibaseQualityConstraints/modules/gadget.js?63f1d:111:5
mightThrow@https://www.wikidata.org/w/resources/lib/jquery/jquery.js?6a07d:3534:21
resolve/</process<@https://www.wikidata.org/w/resources/lib/jquery/jquery.js?6a07d:3602:12

Happens in safemode=1.
Another item I could reproduce this on is https://www.wikidata.org/wiki/Q1.

Event Timeline

Restricted Application added a project: Wikidata. · View Herald TranscriptDec 27 2018, 12:27 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Change 481487 had a related patch set uploaded (by Lucas Werkmeister (WMDE); owner: Lucas Werkmeister (WMDE)):
[mediawiki/extensions/WikibaseQualityConstraints@master] Fix method references in gadget

https://gerrit.wikimedia.org/r/481487

Lucas_Werkmeister_WMDE triaged this task as High priority.

If I understand correctly, this should mean that display of all constraint check results is broken on any page with even one cached constraint check result. Triaging “High” for now and adding to campsite board as urgent for that reason.

Change 481487 merged by jenkins-bot:
[mediawiki/extensions/WikibaseQualityConstraints@master] Fix method references in gadget

https://gerrit.wikimedia.org/r/481487

I have no clue why this is only reproducible in ?safemode=1, but I can confirm that the error appears on https://www.wikidata.org/wiki/Q42?safemode=1. (You might need to load the page twice to populate the cache, not sure.) The fix will probably be deployed on January 9th, so let’s see if the error vanishes then.

Lucas_Werkmeister_WMDE lowered the priority of this task from High to Normal.Dec 28 2018, 11:45 AM

But let’s lower the priority if this doesn’t seem to happen on normal page loads.

I have no clue why this is only reproducible in ?safemode=1

It happens in either mode (at least for me). The statement

Happens in safemode=1.

was just meant to confirm that I had tried safemode, too.

Okay, indeed, I could now reproduce it without safe mode too, not sure why it didn’t work (or, well, did work) earlier. Thanks.

(Waiting for testing until this is deployed on the live system.)

Addshore moved this task from incoming to in progress on the Wikidata board.Jan 11 2019, 10:10 AM
Lydia_Pintscher closed this task as Resolved.Jan 14 2019, 10:06 AM

This seems to be gone now \o/