Page MenuHomePhabricator

eslint-config-node-services has unmeet peer dependencies
Closed, DuplicatePublic

Description

npm reports

npm WARN eslint-config-node-services@2.2.5 requires a peer of eslint@^4.12.0 but none was installed.
npm WARN eslint-config-node-services@2.2.5 requires a peer of eslint-config-wikimedia@^0.5.0 but none was installed.

however current versions are

"eslint": "^5.0.0",
"eslint-config-wikimedia": "^0.9.0",

can we update the peer requirements to the required versions?

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 31 2018, 10:00 AM
Physikerwelt triaged this task as Low priority.Dec 31 2018, 10:00 AM
Physikerwelt added a project: good first task.

We are removing eslint-config-node-services altogether as part of T210460: Eliminate usage of mocha-eslint, marking as duplicate.