Page MenuHomePhabricator

debian-glue does not support autopkgtest version 5
Closed, ResolvedPublic

Description

https://gerrit.wikimedia.org/r/#/c/integration/config/+/463507/ proposes to disable autopkgtest with ADT="skip".

That seems to be from /usr/share/jenkins-debian-glue/pbuilder-hookdir/B20autopkgtest which is provided by jenkins-debian-glue package last modified in May. It was running fine previously. On Stretch adt-run is part of autopkgtest, I guess in Unstable it has been moved to a standalone package.

The hook does:

apt-get install -y autopkgtest apt-utils pbuilder

So probably we would need to adjust jenkins-debian-glue to install whatever package provides adt-run if it is not part of autopkgtest?

The debian glue wrapper build-and-provide-package would skip it when ADT is not set eg:

autopkg_run() {
  case "${ADT:-}" in
   *)
     echo "*** Skipping external autopkgtests as ADT is neither set to 'external' nor 'all' ***"
     return 0
     ;;

Probably the hook should handle it in a better way for the case when ADT is not set.


The root cause is autopkgtest changed and no more ships adt-run. jenkins-debian-glue v0.19.0 has support for it (we run a fork of v0.18.4): https://github.com/mika/jenkins-debian-glue/commit/9e2117c2f8c25fdccb8f6fd423f8b53d463050de

Event Timeline

hashar created this task.Jan 2 2019, 11:17 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 2 2019, 11:17 AM
hashar updated the task description. (Show Details)Jan 2 2019, 11:20 AM
hashar closed this task as Resolved.Mar 22 2019, 11:23 PM
hashar claimed this task.

I have upgraded to jenkins-debian-glue v0.20.0