Page MenuHomePhabricator

Wikisource {{Template:Rule}} is not visible in the footer
Closed, ResolvedPublic

Description

Expected:
The display of a horizontal line in the footer of a page in the Page namespace.

Current status:
The line is not visible.

To Test:
This was tested in Windows 10 64bit, with Firefox Quantum 64.0, and then trying to replicate the results in Vivaldi as well.

Tried using Vivaldi 2.3.1401.7 Official Build, but currently this is not possible because of the bug reported in T212999, so please use Firefox.

Open browser to this link. https://en.wikisource.org/wiki/Page:Houses_and_House-Life_of_the_American_Aborigines.djvu/317.

The page appears is 'Read' mode.

This page has a reference in the footer.

Scroll down to the end of page where the reference is displayed.

There should be a horizontal line above the reference.

Click 'Edit' to see the contents in text mode.

Scroll down to the end, and click the [Show Preview] button.

The horizontal line shows up in 'Preview' mode but not in 'Read' mode.

{{rule}} is the wikisource template which draws the line.

Comparison test.

Replace the {{rule}} with the HTML <hr> and this shows up in both 'Preview' and 'Read' mode.

Event Timeline

Ineuw created this task.Jan 7 2019, 5:07 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 7 2019, 5:07 AM
Ineuw updated the task description. (Show Details)Jan 7 2019, 6:00 AM

Thanks for the good steps!
If you right-click and choose "Inspect Element" you can see in the Developer Tools that <hr style="background-color: #000; color: #000; width: auto; margin: 2px auto 2px auto;"> exists, however the width: auto somehow ends up with a value of 0 (see the "Box Model" under "Layout"):

@Ineuw - the "visibility" of this and other templates will back within one/two days after reverting the changes (mw-parser-output -> display: flex), which cause these problems, see: T209939

Ineuw added a comment.Jan 8 2019, 4:45 AM

@Aklapper, @Zdzislaw

Thanks to both of you. I saw the <hr> auto issue, and I have no problem waiting for the "visibility" issue to be resolved however long it takes.

Xover added a subscriber: Xover.Jan 9 2019, 11:43 AM
Xover added a comment.Jan 9 2019, 9:00 PM

Quick update from enWS: 1.33/wmf.12 is now live there and a quick check suggests it fixes the disappearing horizontal rule. IOW this probably confirms this was caused by T209939.

Ineuw added a comment.Jan 11 2019, 1:22 AM

Everything is fine. Thank you. Please close this report.

Aklapper closed this task as Resolved.Jan 11 2019, 3:00 PM

@Ineuw: For future reference, feel free to do so yourself by setting the status of this report to "Resolved" via the Add Action...Change Status dropdown.