Page MenuHomePhabricator

"Prevent logged-in users from editing from this IP address" always shown when blocking accounts but has no effect
Closed, ResolvedPublic

Description

Steps to reproduce:

  1. Go to Special:Block
  2. Put in an account
  3. Notice the "Prevent logged-in users..." checkbox disappears, which is expected
  4. Block the account
  5. Go back to Special:Block/Username
  6. The "Prevent logged-in users..." is shown and is checked.

I believe "Prevent logged-in users..." isn't supposed to be there at all for accounts, only when blocking IPs. Regardless:

  1. Uncheck "Prevent logged-in users..." and check another option (so that you can re-block)
  2. Re-block
  3. Go back to Special:Block/Username, the "Prevent logged-in users..." is still checked.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 8 2019, 11:42 PM

Adding Anti-Harassment in case this is related to their recent work on blocking.

Restricted Application added a subscriber: MGChecker. · View Herald TranscriptJan 8 2019, 11:43 PM

Leon, on which environment is this happening? Production? Beta?

MusikAnimal added a comment.EditedJan 9 2019, 12:16 AM

Production, reported on English Wikipedia. It was a little scary because it looks like a hard block (block underlying IPs) even if you did a soft block, but I think it might just be a UI issue.

I checked testwiki, which has the new UI with partial blocks. The equivalent of the same bug isn't there, so sounds like a regression with the old UI.

This is broken on https://test2.wikipedia.org which is running 1.33.0-wmf.9 but it is *fixed* on https://test-commons.wikimedia.org which is running 1.33.0-wmf.12.

I assume this is related to T212808 but I can confirm in a bit.

Correct me if I'm wrong, but isn't this a duplicate of T209664?

I can confirm that this is fixed by the fix for T212808 - after this, the checkbox no longer reappears.

@Amorymeltzer Thanks for pointing out T209664 - yes, it's the same issue, and fixed by the same fix.

TBolliger triaged this task as High priority.Jan 9 2019, 4:30 PM
TBolliger moved this task from Backlog to User blocking on the MediaWiki-User-management board.
dbarratt moved this task from Review to In progress on the Anti-Harassment (Alef — א) board.
TBolliger closed this task as Resolved.Jan 16 2019, 7:53 PM
TBolliger claimed this task.
TBolliger moved this task from In progress to Done on the Anti-Harassment (Alef — א) board.