Page MenuHomePhabricator

HTTP Error 500 trying to access Coverage reports on https://doc.wikimedia.org/
Closed, ResolvedPublic

Description

Got the following error

Error
Our servers are currently under maintenance or experiencing a technical problem. Please try again in a few minutes.
Request from 129.0.79.193 via cp1081 cp1081, Varnish XID 823375843
Error: 500, Internal Server Error at Wed, 09 Jan 2019 16:50:02 GMT

Details

Related Gerrit Patches:
operations/puppet : productiondoc: add php7.2-xml package

Event Timeline

D3r1ck01 created this task.Jan 9 2019, 4:52 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 9 2019, 4:52 PM

Not sure which project tag to use here!

D3r1ck01 updated the task description. (Show Details)Jan 9 2019, 4:53 PM

Hmmm... Just loaded again now and it's same issue!

D3r1ck01 added a comment.EditedJan 9 2019, 5:04 PM

https://doc.wikimedia.org/ works just fine but trying to view coverage reports shows an internal server error.

Aklapper renamed this task from Error while loading docs.wikimedia.org/cover/ to HTTP Error 500 trying to access Coverage reports on https://doc.wikimedia.org/.Jan 9 2019, 5:17 PM
Dzahn added a subscriber: hashar.Jan 9 2019, 6:06 PM
hashar added a subscriber: Dzahn.

@Dzahn and I have migrated doc.wikimedia.org to a new host ( T137890 ).

https://docs.wikimedia.org/cover/ emits a location header to https://docs.wikimedia.org/ . But I don't get an error 500 right now.

The http version http://docs.wikimedia.org/cover/ does redirect to the proper https url https://docs.wikimedia.org/cover/

hashar added a comment.Jan 9 2019, 7:43 PM

I can't access the Apache 2 server logs due to lack of permissions :(

$ ls -lad /var/log/apache2
drwxr-x--- 2 root adm 4096 Jan  9 06:25 /var/log/apache2

And obviously just after my previous comment I got a 500 while reaching https://doc.wikimedia.org/cover/

via cp1075 cp1075, Varnish XID 579751165<br>Error: 500, Internal Server Error at Wed, 09 Jan 2019 19:42:30 GMT

hashar added a comment.Jan 9 2019, 8:35 PM

cd /srv/docroot/org/wikimedia/doc/cover
php -a

Then in the php interactive session:

$_SERVER['DOCUMENT_ROOT']='/srv/docroot/org/wikimedia/doc/';
$_SERVER['SCRIPT_NAME'] = 'cover/index.php';
require('index.php');
PHP Warning:  Uncaught Error: Class 'SimpleXMLElement' not found in /srv/docroot/shared/CoveragePage.php:153
Stack trace:
#0 /srv/docroot/shared/CoveragePage.php(111): CoveragePage->parseClover('<?xml version="...')
#1 /srv/docroot/org/wikimedia/doc/cover/index.php(26): CoveragePage->handleCoverageIndex()
#2 php shell code(1): require('/srv/docroot/or...')
#3 {main}
  thrown in /srv/docroot/shared/CoveragePage.php on line 153

So we need at least php7.2-xml to be added.

Change 483223 had a related patch set uploaded (by Hashar; owner: Hashar):
[operations/puppet@production] doc: add php7.2-xml package

https://gerrit.wikimedia.org/r/483223

Change 483223 merged by Dzahn:
[operations/puppet@production] doc: add php7.2-xml package

https://gerrit.wikimedia.org/r/483223

Paladox closed this task as Resolved.Jan 9 2019, 8:50 PM
Paladox assigned this task to hashar.
hashar added a comment.Jan 9 2019, 8:51 PM

https://doc.wikimedia.org/cover/ works now. We lacked the PHP xml module.

D3r1ck01 added a comment.EditedJan 9 2019, 8:52 PM

Wooooo, so we would have access to our code coverage reports again. Thanks @hashar, @Dzahn and @Paladox for working on this. 🎉🎉🎉. I can confirm that it works for me too :)