Page MenuHomePhabricator

unable to access Eventlogging via stat1006
Closed, ResolvedPublic

Description

Hi OPs & DB admins,

I need to access Eventlogging to analyze data for T209882. I thought I was in all the right groups but when I run the test query I get an access denied response.

sir-nose:~ jtmorgan$ ssh stat1006.eqiad.wmnet
Linux stat1006 4.9.0-8-amd64 #1 SMP Debian 4.9.110-3+deb9u4 (2018-08-21) x86_64
Debian GNU/Linux 9.5 (stretch)
stat1006 is a Statistics general compute node (non private data) (statistics::cruncher)
The last Puppet run was at Wed Jan  9 21:12:00 UTC 2019 (0 minutes ago). 
Debian GNU/Linux 9 auto-installed on Wed Jul 12 13:47:00 UTC 2017.
Last login: Mon Jan  7 23:36:42 2019 from 2620:0:861:3:208:80:154:86
jmorgan@stat1006:~$ mysql --defaults-extra-file="/etc/mysql/conf.d/research-client.cnf" -h analytics-slave.eqiad.wmnet -e "select left(timestamp,8) ts , COUNT(*) from log.NavigationTiming_10785754 where timestamp >= '20150402062613' group by ts order by ts"; 
ERROR 1045 (28000): Access denied for user 'research'@'10.64.53.31' (using password: YES)

Can you re-approve me for access, and/or help me debug?

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 9 2019, 9:19 PM
Ottomata closed this task as Resolved.Jan 9 2019, 9:32 PM
Ottomata claimed this task.
Ottomata added a subscriber: Ottomata.

@Capt_Swing The issue is the presence of the .my.cnf file in your home dir on stat1006. It's being read by default and overriding the research-client.cnf conf file. Move or rename it out of the way and it will work!

excellent, thank you so much @Ottomata