Page MenuHomePhabricator

Fix `The save has failed. (failed-save) (MediawikiApi::ApiError)` daily ruby browser test error
Closed, DeclinedPublic

Description

Currently, many of the daily ruby browser tests are failing.

The Investigation T211696 has revealed that the largest amount of tests fail with the error-message "The save has failed. (failed-save) (MediawikiApi::ApiError)"

Investigate and fix the cause for this error.

The Mediawiki wiki has a guide on how to run these tests locally. Though note, that I was not able to reproduce these errors locally.

Event Timeline

Michael created this task.Jan 10 2019, 2:01 PM
Restricted Application added a project: Wikidata. · View Herald TranscriptJan 10 2019, 2:01 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Addshore moved this task from incoming to ready to go on the Wikidata board.Feb 11 2019, 9:00 AM
alaa_wmde closed this task as Declined.Apr 16 2019, 4:05 PM
alaa_wmde added a subscriber: alaa_wmde.

We prioritized rewriting ruby tests as javascript tests T208851