Page MenuHomePhabricator

Fix `Watir::Wait::TimeoutError` daily ruby browser test error
Closed, DeclinedPublic

Description

Currently, many of the daily ruby browser tests are failing.

The Investigation T211696 has revealed that some tests fail with the timed out after 15 seconds, Element was not visible in 15 seconds (Watir::Wait::TimeoutError) error message.

Investigate and fix the cause for this error.

The Mediawiki wiki has a guide on how to run these tests locally. These errors also occured locally, but for different tests.

Event Timeline

Michael triaged this task as Normal priority.Jan 10 2019, 2:27 PM
Michael created this task.
Addshore moved this task from incoming to ready to go on the Wikidata board.Feb 11 2019, 9:00 AM
alaa_wmde closed this task as Declined.Apr 16 2019, 4:05 PM
alaa_wmde added a subscriber: alaa_wmde.

We prioritized rewriting ruby tests as javascript tests T208851