Page MenuHomePhabricator

Fix `RSpec::Expectations::ExpectationNotMetError` daily ruby browser test errors
Closed, DeclinedPublic

Description

Currently, many of the daily ruby browser tests are failing.

The Investigation T211696 has revealed that some of the geo related tests fail with a RSpec::Expectations::ExpectationNotMetError.

Investigate and fix the cause for this error.

The Mediawiki wiki has a guide on how to run these tests locally. Though note, that I was not able to reproduce these errors locally.

Event Timeline

Michael triaged this task as Normal priority.Jan 10 2019, 4:47 PM
Michael created this task.

Here’s one of the failed expectations:

@@ -1,2 +1,6 @@
++
+-
+1 km
+Wikimedia maps | Map data © OpenStreetMap contributors
 52°29'53"N, 13°22'51"E

The other three in #451 are identical, just with a different coordinate string.

This looks like it broke due to T184933: the <mapframe> we now use to display coordinates introduces some extra text into the page (zoom buttons, scale and credits) which the tests don’t expect. It might be possible to reproduce this locally by installing the Kartographer extension, though I was unfortunately unable to do so back when reviewing T184933.

Addshore moved this task from incoming to ready to go on the Wikidata board.Feb 11 2019, 9:00 AM
alaa_wmde closed this task as Declined.Apr 16 2019, 4:05 PM
alaa_wmde added a subscriber: alaa_wmde.

We prioritized rewriting ruby tests as javascript tests T208851