Page MenuHomePhabricator

Offer a way to go to the previous or next non-deleted edit in an edit history of a page
Closed, ResolvedPublicBUG REPORT

Description

Original description

When someone has clicked on an entry in an edit history (of deleted edits or of non-deleted edits), and thus is reading one of the edits in that history, it would be useful for him to be able to click once or press a keyboard key and thus step to the previous or next edit of that page as in the edit history which he had clicked on.

Detailed description

Copied from enwiki
On this page history, you will note that three consecutive edits in February and March 2020 have been redacted out of the history. Okay, I understand that, but now look at this.

  • First select an edit a bit earlier (say this one).
  • Click on "Next edit →" and it works.
  • Click on "Next edit →" again and now you get "You cannot view this diff because one or both of the revisions have been '''removed from the public archives.'''"
  • But now click "Next edit →" ''again'', and you get: "One revision of this difference (940771782) was not found" -- and no forward link this time.

This is not helpful. Since three edits were removed, I expected one of two things. (A) The "You cannot view this diff" screen might repeat twice, and then "Next edit →" would take me to this edit -- the next one that I am allowed to see.

Or better yet, (B) on the "You cannot view this diff" screen, instead of a non-useful "Next edit →" link it could have had "Next publicly available edit →", which would take me directly to the above one (or a "Next edit →" link that would have that behavior).

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 12 2019, 10:11 AM
Aklapper renamed this task from Stepping along an edit history to Offer a way to go to the previous or next non-deleted edit in an edit history of a page.Jan 12 2019, 11:13 AM
Anthony_Appleyard updated the task description. (Show Details)
Ammarpad added a subscriber: Ammarpad.

Article class overrides DifferenceEngine handling of showing the diff but fails to appropriately handle the situation where revision is null because of permission not because it doesn't exist.

Ammarpad updated the task description. (Show Details)Apr 12 2020, 9:24 AM

Change 588149 had a related patch set uploaded (by Ammarpad; owner: Ammarpad):
[mediawiki/core@master] Show standard diff elements if revision is null only because of permission

https://gerrit.wikimedia.org/r/588149

This fixes a reproducible bug, so I think it should not be considered a "new feature". The merged task T225189 has more simpler steps to reproduce

Ammarpad changed the subtype of this task from "Task" to "Bug Report".Oct 8 2020, 8:26 AM

Change 588149 merged by jenkins-bot:
[mediawiki/core@master] Show standard diff elements if revision is null only because of permission

https://gerrit.wikimedia.org/r/588149

Ammarpad closed this task as Resolved.Oct 21 2020, 7:38 AM
Ammarpad claimed this task.