Page MenuHomePhabricator

Lost file Juan_Guaidó.jpg
Closed, ResolvedPublic

Description

The commons file Juan Guaidó.jpg, uploaded on 2019-01-06T12:41:45Z is missing, url shows File not found: /v1/AUTH_mw/wikipedia-commons-local-public.ca/c/ca/Juan_Guaid%C3%B3.jpg

Some thumbnails are still available on (varnish?) cache:

Additionally, there's a new version of that image on File:Juan Guaidó restored version.jpg but trying to move it over the former produces a MWException (likely because the file is already missing): [XDtcVApAICEAALl5bPYAAABT] 2019-01-13 15:42:13

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 13 2019, 3:52 PM

to me the image is not visible on Wikipedia spanish

abian added a subscriber: abian.Jan 13 2019, 3:56 PM

It's probably on esams varnish cache but not on codfw.

The MWException is T210739.

Aklapper updated the task description. (Show Details)Jan 13 2019, 4:06 PM
Daimona removed a subscriber: Daimona.Jan 13 2019, 4:07 PM
Aklapper edited projects, added media-storage; removed Multimedia.Jan 13 2019, 4:07 PM
JOAN added a subscriber: JOAN.Jan 13 2019, 4:14 PM

I can no longer access to the thumbnails from the description.

Aklapper added a project: Operations.EditedJan 13 2019, 11:03 PM

No matter if I set eqiad, esams or codfw for the xxxxx in wget -S --header 'host: upload.wikimedia.org' 'https://upload-lb.xxxxx.wikimedia.org/wikipedia/commons/c/ca/Juan_Guaid%C3%B3.jpg' --no-check-certificate, I always get a 404 at this stage.

It's probably on esams varnish cache but not on codfw.

Tentatively CC'ing Operations because of this earlier comment; feel free to remove again.

Jeff_G added a subscriber: Jeff_G.Jan 14 2019, 1:42 PM
CDanis triaged this task as Normal priority.Jan 14 2019, 5:03 PM
CDanis assigned this task to jcrespo.
CDanis added subscribers: fgiunchedi, CDanis.

@jcrespo and @fgiunchedi are going to take a look at what happened to the file in Swift.

I pulled the swift logs for that file (and similar) below, looks like similarly-named versions where also uploaded and deleted. The file in question was deleted on Jan 13th.

On the MW side we have to investigate what happened that caused the file to be deleted. We can restore it though since it has been moved to "the trash", does MW have facilities for that?

Jan  6 12:41:44 ms-fe1007 proxy-server: PUT /v1/AUTH_mw/wikipedia-commons-local-public.ca/c/ca/Juan_Guaid%25C3%25B3.jpg HTTP/1.0 201 
Jan 11 20:26:46 ms-fe1006 proxy-server: PUT /v1/AUTH_mw/wikipedia-commons-local-public.40/4/40/Juan_Guaido.jpg HTTP/1.0 201
Jan 13 01:42:24 ms-fe1007 proxy-server: PUT /v1/AUTH_mw/wikipedia-commons-local-public.98/9/98/Juan_Guaid%25C3%25B3_restored_version.jpg HTTP/1.0 201
Jan 13 06:39:48 ms-fe1005 proxy-server: Copying object from /v1/AUTH_mw/wikipedia-commons-local-public.ca/c/ca/Juan_Guaidó.jpg to /v1/AUTH_mw/wikipedia-commons-local-deleted.s3/s/3/9/s39c26kogyfzicy2zii8gx0htqz09o7.jpg (txn: txd39e73e9b910462593a74-005c3add34)
Jan 13 06:39:48 ms-fe1005 proxy-server: DELETE /v1/AUTH_mw/wikipedia-commons-local-public.ca/c/ca/Juan_Guaid%25C3%25B3.jpg HTTP/1.0 204 
Jan 13 21:58:18 ms-fe1007 proxy-server: PUT /v1/AUTH_mw/wikipedia-commons-local-public.f0/f/f0/Juan_Guaido_recortada.jpg HTTP/1.0 201 
Jan 14 00:39:00 ms-fe1005 proxy-server: Copying object from /v1/AUTH_mw/wikipedia-commons-local-public.40/4/40/Juan_Guaido.jpg to /v1/AUTH_mw/wikipedia-commons-local-deleted.ic/i/c/y/icyqmje4kh31ie9gr911o7efsh6pdws.jpg (txn: txc16dead56686426ebefcd-005c3bda24)
Jan 14 00:39:00 ms-fe1005 proxy-server: DELETE /v1/AUTH_mw/wikipedia-commons-local-public.40/4/40/Juan_Guaido.jpg HTTP/1.0 204

Could you try to restore it @Platonides using the wiki admin tools before trying some SQL?

This is my speculation. I think that the root cause is bug T210739.

There is an edit history merge request in this file's (Juan Guaidó.jpg) talk page. Someone has tried to merge edit history, but because of bug T210739... it will fail with fatal error. I think that MediaWiki has taken that delete action only for the file. Because of that bug, there is no delete log or anything. T210739 needs solution asap.

This comment was removed by User100100.

Could you try to restore it @Platonides using the wiki admin tools before trying some SQL?

There is no entry to restore on the wiki.

No link stating that there is a delete version. Special:Undelete/File:Juan_Guaid%C3%B3.jpg is empty.

The file sha1 is f07a6b50bca89243bc721b1df85ec6baf740ebf7, so I would expect it¹ to be named s39c26kogyokss80kw48kck00os8ocw.jpg and viewable at this url, but it says it does not exist.

Peeking into the db from labs, it's not listed on filearchive, either.

I expect it would be somewhere in swift even if not viewable from mediawiki side, though.

¹ base_convert('f07a6b50bca89243bc721b1df85ec6baf740ebf7', 16, 36);
² select * from filearchive where fa_sha1='f07a6b50bca89243bc721b1df85ec6baf740ebf7' And fa_deleted=0;

Thanks, yes, as Filippo said above, it has been deleted (and it is available) on swift, but not on metadata. We can do 2 things- reupload it, or perform a deletion with SQL and recover it in the normal way. I will need help from a mw developer for the second option.

Recover in the normal way would be nice, because otherwise people are wondering where the original file disappeared.

jcrespo removed jcrespo as the assignee of this task.Jan 22 2019, 9:09 AM
jcrespo added a project: Multimedia.
jcrespo added a subscriber: jcrespo.

I am blocked on someone with Mediawiki file metadata workflow knowledge to guide me on what to do here.

jijiki added a subscriber: jijiki.Jan 22 2019, 9:15 AM
User100100 added a comment.EditedJan 26 2019, 7:28 PM

Seems like that this file is reuploaded to Commons, so there is no need to restore anything(?).

https://commons.wikimedia.org/wiki/File:Juan_Guaid%C3%B3_restored_version.jpg

EDIT: I mean I noticed this just now because, the old file page is now deleted from Commons.

Delete log:

13:35, 26 January 2019 -revi (talk | contribs) deleted page File:Juan Guaidó.jpg (Exact or scaled-down duplicate: File:Juan Guaidó restored version.jpg)

Ankry added a subscriber: Ankry.Jan 28 2019, 3:25 PM

the problematic version restored after revi's delete and history merged on-wiki.
Is there still any phabricator-related issue here?

Is there still any phabricator-related issue here?

I don't think so- doing as above was my first suggestion, as doing manually is not easy and can break the consistency of the database.

This comment was removed by User100100.
User100100 added a comment.EditedJan 29 2019, 5:44 AM

Problem is solved. So this bug should be closed.

jcrespo closed this task as Resolved.Jan 29 2019, 7:56 AM
jcrespo claimed this task.
jcrespo reassigned this task from jcrespo to revi.
Restricted Application added a project: User-revi. · View Herald TranscriptJan 29 2019, 7:58 AM
revi moved this task from Incoming to Radar on the User-revi board.Feb 7 2019, 3:42 AM