Page MenuHomePhabricator

Help panel: clicking the close icon doesn’t make the question text be deleted
Closed, DeclinedPublic

Description

Steps to reproduce

  1. Open an arbitrary page
  2. Open the Help pane
  3. Fill a random question
  4. Click “Continue”
  5. Close the Help pane without submitting the question
  6. Go to another arbitrary page
  7. Open the Help pane
  8. Expected: The field for your question is empty
  9. Happened: The field for your question contain the random question you filled before.

Event Timeline

Urbanecm created this task.Jan 13 2019, 5:13 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 13 2019, 5:13 PM

I'm for keeping that text because:

  • the user may be checking another page and then want to come back to the article and post it
  • the case may exist on the page the user is on ATM
  • the user may have forgotten to post it
MMiller_WMF renamed this task from Help pane: Clicking the close icon doesn’t make the question text be deleted to Help panel: clicking the close icon doesn’t make the question text be deleted.Jan 17 2019, 5:24 PM

Yeah, this was by design for the reasons listed by @Trizek-WMF. We could thinking about persisting the question text per unique page (so typing "ABC" in the help panel on Page X and "DEF" on page Y, closing both, opening Page X you'd see "ABC" and opening page Y you'd see "DEF") but that seems like over-engineering to me.

I'm for keeping that text because:

  • the user may be checking another page and then want to come back to the article and post it

Don't users do this in a separate tab?

  • the case may exist on the page the user is on ATM
  • ?
  • the user may have forgotten to post it
  • Well, I think they'll forgot they filled something somewhere as well.

Plus: Do we have some other services doing similar things?

MMiller_WMF closed this task as Declined.Jan 23 2019, 12:46 AM

@Urbanecm -- thanks for filing this, but I think the safest thing to do is leave it alone. If a user wants to delete what they already typed into the box, they'll be able to do it. I'm going to decline this for now.