Page MenuHomePhabricator

Custom protection messages do not show up on extremely minor language change
Closed, InvalidPublic

Description

Consider the following scenario:
1 - A user goes to meta.wikimedia.org and tries to edit the main page.
He or she gets a message reading like "This page is currently protected so that only administrators can edit it.".
2 - Then the language is changed from en-US to en-GB (British English). Then the same page is again visited.
This time, the user gets a generic error saying that "This page has been protected to prevent editing or other actions. ".

I suspect this is due to translate.wiki considering en-GB as a whole new language, but can we make messages such as these the same throughout all English 'derivatives'? The loss of fidelity, if any, should be negligible.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 15 2019, 5:58 PM
Ammarpad closed this task as Invalid.Jan 16 2019, 4:33 AM

This is not a bug. The uncustomized en-GB message comes from MediaWiki:Protectedpagetext/en-GB while the customized for "en" comes from MediaWiki:Protectedpagetext. You'll get the same default message when you try to edit the page while having French as your interface language because MediaWiki:Protectedpagetext/fr was not customized.

To have the customized message with en-GB interface language, you need to override the default content of MediaWiki:Protectedpagetext/en-GB, and a local sysop can do this.

That's why I asked whether it's possible to display the same error message through MediaWiki itself. After all, displaying the default message (i.e, en-US) for en-GB shouldn't be a big deal - even for languages like fr.

That's why I asked whether it's possible to display the same error message through MediaWiki itself. After all, displaying the default message (i.e, en-US) for en-GB shouldn't be a big deal - even for languages like fr.

This is already how MediaWiki works. The default text on MediaWiki:Protectedpagetext is the same error message that MediaWiki displays on all wikis unless overridden locally, which is what is done with MediaWiki:Protectedpagetext.

If you mean, you want the text of MediaWiki:Protectedpagetext to be made the default in the core, this is something that won't be done, for obvious reasons.