Page MenuHomePhabricator

Downloaded PDF has utterly broken kerning, making some text unreadable
Closed, ResolvedPublic

Description

To reproduce: visit https://en.wikipedia.org/wiki/The_Fighting_Temeraire, click "Download as PDF" in the sidebar.

You get a file like this:

In some places the positioning of some characters is just entirely messed up. In the worst cases, two characters are mispositioned so badly, their order is swapped:

Additionally, just about every instance of the character "T" is badly kerned, either way too close to or way too far from the neighboring character. Perhaps the main issue is also caused by a kerning problem?

Event Timeline

matmarex created this task.Jan 15 2019, 9:05 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 15 2019, 9:05 PM
TheDJ closed this task as Resolved.Jun 4 2019, 11:50 AM
TheDJ claimed this task.
TheDJ added a subscriber: TheDJ.

This seems fixed with Proton deployed.