Page MenuHomePhabricator

High Cloud Services Wiki Replicas lag is suboptimal for Petscan
Closed, InvalidPublic

Description

In the past couple of days, Petscan searches for en.wikipedia articles with no wikidata item have been returning articles that have wikidata items.

I think the issue may be higher than normal replication lag from production to labs databases - cf. https://tools.wmflabs.org/replag/ currently showing replags of up to 6 hours.

I use a consistent set of petscans on roughly a daily basis & have done for months & years. Current behavior - returning articles that have wikidata items - is not normal. Petscan is normally very reactive to changes made, such that one can run a petscan, create items for articles, and run the same petscan pretty much immediately and see the articles have disappeared from the list.

Grateful for any info or input on whether there is an issue here, and if so, a prognosis on likely time to fix. thx.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 16 2019, 11:57 PM
bd808 added a subscriber: bd808.Jan 21 2019, 8:21 PM

Replag for the s8 segment which hosts the wikidatawiki database replica is at the time of this comment 3m14s. Although a replag of 0 is ideal, there is not a lot that can be done on the Wiki Replica side to correct the variable amount of replication time delays that occur. These are primarily caused by variations in system load and time rate of change of data on the production database servers which feed data to the Wiki Replicas servers.

bd808 closed this task as Invalid.Jan 25 2019, 6:04 AM

Closing as invalid because there is nothing actionable in the report and replag appears to be within normal variance at the current time.