Page MenuHomePhabricator

Add Wikimedia\Services to phan configuration
Closed, ResolvedPublic

Description

Without the temporary fix introduced as reaction to the initial UBN state of this ticket, the following problems occur.

Class extends undeclared class \MediaWiki\Services\ServiceContainer
Reference to undeclared class \MediaWiki\Services\ServiceContainer
Call to method getContainerForRepository from undeclared class \MediaWiki\Services\ServiceContainer
...

Example of failure before : https://integration.wikimedia.org/ci/job/mwext-php70-phan-docker/19246/
Likely due to: T211608: Librarize includes/services/

AC

  • phan is configured accordingly (stubs maybe?)

Details

Related Gerrit Patches:
mediawiki/extensions/Wikibase : masterRevert "Temporarily skip PhanUndeclaredClassMethod phan check"
mediawiki/extensions/Wikibase : masterTemporarily skip PhanUndeclaredClassMethod phan check
mediawiki/extensions/Wikibase : masterTest if suppressing PhanUndeclaredClassMethod fixes CI

Related Objects

Event Timeline

Tarrow created this task.Jan 17 2019, 10:06 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 17 2019, 10:06 AM
Tarrow triaged this task as Unbreak Now! priority.Jan 17 2019, 10:06 AM

CI blocked hence UBN :(

Restricted Application added subscribers: Liuxinyu970226, TerraCodes. · View Herald TranscriptJan 17 2019, 10:06 AM

Change 484998 had a related patch set uploaded (by WMDE-leszek; owner: WMDE-leszek):
[mediawiki/extensions/Wikibase@master] Temporarily skip PhanUndeclaredClassMethod phan check

https://gerrit.wikimedia.org/r/484998

Change 484999 had a related patch set uploaded (by Tarrow; owner: Tarrow):
[mediawiki/extensions/Wikibase@master] Test if suppressing PhanUndeclaredClassMethod fixes CI

https://gerrit.wikimedia.org/r/484999

investigating...

Teh patches are there because From IRC:

<leszek_wmde> purple phan got updated after 3 years?
9:59 AM how about skipping the phan check for now, and trying to figure our what happens?
9:59 AM tests/phan/config.php and suppress_issue_types section out there

Change 484999 abandoned by Pablo Grass (WMDE):
Test if suppressing PhanUndeclaredClassMethod fixes CI

Reason:
Duplicate of Iae6407c43c78b91133f1096978dba08cbf34cb5a (thanks, Tarrow no less!)

https://gerrit.wikimedia.org/r/484999

Looking into remaining failures...

Pablo-WMDE renamed this task from Wikibase CI failing due to phan to Wikibase CI failing due to phan (Wikimedia\Services).Jan 17 2019, 10:57 AM

(Temporarily) resolved by https://gerrit.wikimedia.org/r/c/mediawiki/extensions/Wikibase/+/484998
Will downgrade once in the main line.

Change 484998 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] Temporarily skip PhanUndeclaredClassMethod phan check

https://gerrit.wikimedia.org/r/484998

Pablo-WMDE lowered the priority of this task from Unbreak Now! to High.Jan 17 2019, 11:45 AM

oh, sorry for duplicating the effort. I dropped out of IRC, and also didn't refresh the task so missed all the comments. This is the last time such misbehaviour of mine happens.

Pablo-WMDE renamed this task from Wikibase CI failing due to phan (Wikimedia\Services) to Add Wikimedia\Services to phan configuration.Jan 17 2019, 11:52 AM
Pablo-WMDE updated the task description. (Show Details)
Addshore moved this task from incoming to in progress on the Wikidata board.Jan 17 2019, 4:36 PM

Is this still an issue now that the changes updating Wikibase and WikibaseLexeme for the rename have been merged? The remaining repository, BlueSpiceFoundation, is only depended on by other BlueSpice things as far as I can tell from integration-config.

Change 485682 had a related patch set uploaded (by Lucas Werkmeister (WMDE); owner: Lucas Werkmeister (WMDE)):
[mediawiki/extensions/Wikibase@master] Revert "Temporarily skip PhanUndeclaredClassMethod phan check"

https://gerrit.wikimedia.org/r/485682

Change 485682 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] Revert "Temporarily skip PhanUndeclaredClassMethod phan check"

https://gerrit.wikimedia.org/r/485682

Lucas_Werkmeister_WMDE closed this task as Resolved.Jan 21 2019, 7:01 PM

Temporary fix is reverted and CI still seems to work, so I think we can close this – Phan configuration changes are unnecessary because Wikibase now uses the new names of the moved classes. (Sorry @Pablo-WMDE for stealing your ticket, but it looked like you weren’t working on it at the moment.)