Page MenuHomePhabricator

BadMethodCallException: Call to a member function dumpAllVars() on a non-object (boolean)
Open, Needs TriagePublicPRODUCTION ERROR

Description

Error

Request ID: AWhh9wR0zpjgITg63PIx
Request URL: here (the same as T214193)

message
Call to a member function dumpAllVars() on a non-object (boolean) in php-1.33.0-wmf.13/extensions/AbuseFilter/includes/Views/AbuseFilterViewExamine.php:173
trace
#0 /srv/mediawiki/php-1.33.0-wmf.13/extensions/AbuseFilter/includes/Views/AbuseFilterViewExamine.php(27): AbuseFilterViewExamine->showExaminerForLogEntry(string)
#1 /srv/mediawiki/php-1.33.0-wmf.13/extensions/AbuseFilter/includes/special/SpecialAbuseFilter.php(122): AbuseFilterViewExamine->show()
#2 /srv/mediawiki/php-1.33.0-wmf.13/includes/specialpage/SpecialPage.php(569): SpecialAbuseFilter->execute(string)
#3 /srv/mediawiki/php-1.33.0-wmf.13/includes/specialpage/SpecialPageFactory.php(558): SpecialPage->run(string)
#4 /srv/mediawiki/php-1.33.0-wmf.13/includes/MediaWiki.php(288): MediaWiki\Special\SpecialPageFactory->executePath(Title, RequestContext)
#5 /srv/mediawiki/php-1.33.0-wmf.13/includes/MediaWiki.php(862): MediaWiki->performRequest()
#6 /srv/mediawiki/php-1.33.0-wmf.13/includes/MediaWiki.php(517): MediaWiki->main()
#7 /srv/mediawiki/php-1.33.0-wmf.13/index.php(42): MediaWiki->run()
#8 /srv/mediawiki/w/index.php(3): include(string)
#9 {main}

Impact

Presumably low, seen twice in the last 7 days (and together with T214193).

Notes

This happens due to T214193: being unable to unserialize the value, loadVarDump just returns a boolean. However, I guess this could also happen without the other bug.

Event Timeline

Daimona created this task.Jan 18 2019, 6:41 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 18 2019, 6:41 PM
Daimona moved this task from Backlog to Next on the User-Daimona board.Jan 18 2019, 6:41 PM

Change 482499 had a related patch set uploaded (by Daimona Eaytoy; owner: Daimona Eaytoy):
[mediawiki/extensions/AbuseFilter@master] [WIP] Add a maintenance script to clean afl_var_dump

https://gerrit.wikimedia.org/r/482499

Daimona claimed this task.Jan 22 2019, 6:27 PM

Since this is caused by old entries, the script will fix it. Subsequent patches will reinforce the method.

Daimona moved this task from Next to Under review on the User-Daimona board.Jan 22 2019, 6:27 PM
Alroilim closed this task as Declined.Feb 2 2019, 7:20 PM
Alroilim removed Daimona as the assignee of this task.
Alroilim triaged this task as Lowest priority.
Alroilim set Due Date to Feb 1 2019, 9:00 PM.
Alroilim updated the task description. (Show Details)
Alroilim removed subscribers: gerritbot, Aklapper, Daimona.
Restricted Application changed the subtype of this task from "Task" to "Deadline". · View Herald TranscriptFeb 2 2019, 7:20 PM
Gopavasanth reopened this task as Open.Feb 2 2019, 7:41 PM
Gopavasanth assigned this task to Daimona.
Huji raised the priority of this task from Lowest to Needs Triage.Feb 2 2019, 8:03 PM
Huji removed Due Date.
Huji updated the task description. (Show Details)
Huji added subscribers: gerritbot, Aklapper.
Restricted Application changed the subtype of this task from "Deadline" to "Task". · View Herald TranscriptFeb 2 2019, 8:03 PM

Change 482499 had a related patch set uploaded (by Daimona Eaytoy; owner: Daimona Eaytoy):
[mediawiki/extensions/AbuseFilter@master] [WIP] Add a maintenance script to clean afl_var_dump

https://gerrit.wikimedia.org/r/482499

mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:07 PM

Change 482499 merged by jenkins-bot:
[mediawiki/extensions/AbuseFilter@master] Add a maintenance script to clean afl_var_dump

https://gerrit.wikimedia.org/r/482499

I've not seen this for a while. Was the script run? Can this error still be triggered?

Huji added a subscriber: Huji.Apr 29 2020, 7:23 PM

@Daimona can you kindly respond to above and while doing so, decide if this task should be closed as Resolved?

I haven't run the script in production yet, no. I was vaguely planning to do it, but it's still in development. See T246539: Dry-run, then actually run updateVarDumps.

What James said. I'm going to run it on the Beta Cluster tomorrow (probably), then see if it's ready for prod.

I've marked this as blocked by the maintenance run.