Page MenuHomePhabricator

Unable to move pages
Closed, ResolvedPublic

Description

When attempting to move a page, I get an internal error with the following reason:

[54a0b04b1ae5eaa1b6018cc1] /w/index.php?title=Special:MovePage&action=submit TypeError from line 123 of /var/www/live/w/extensions/ArticleRatings/ArticleRatingsHooks.php: Argument 5 passed to AreHooks::onTitleMove() must be an instance of Status, none given, called in /var/www/live/w/includes/Hooks.php on line 177
Backtrace
#0 /var/www/live/w/includes/Hooks.php(177): AreHooks::onTitleMove(Title, Title, User)
#1 /var/www/live/w/includes/Hooks.php(205): Hooks::callHook(string, array, array, NULL)
#2 /var/www/live/w/includes/MovePage.php(243): Hooks::run(string, array)
#3 /var/www/live/w/includes/specials/SpecialMovepage.php(595): MovePage->move(User, string, boolean)
#4 /var/www/live/w/includes/specials/SpecialMovepage.php(128): MovePageForm->doSubmit()
#5 /var/www/live/w/includes/specialpage/SpecialPage.php(522): MovePageForm->execute(NULL)
#6 /var/www/live/w/includes/specialpage/SpecialPageFactory.php(568): SpecialPage->run(NULL)
#7 /var/www/live/w/includes/MediaWiki.php(288): SpecialPageFactory::executePath(Title, RequestContext)
#8 /var/www/live/w/includes/MediaWiki.php(861): MediaWiki->performRequest()
#9 /var/www/live/w/includes/MediaWiki.php(524): MediaWiki->main()
#10 /var/www/live/w/index.php(42): MediaWiki->run()
#11 {main}

MasterAS on Bricki notified me of this (so it's not just me with the problem), and it appears to affect all namespaces.

Event Timeline

Peachey88 updated the task description. (Show Details)Jan 19 2019, 12:17 AM
lcawte moved this task from Backlog to Bugs on the ArticleRatings board.
lcawte added a subscriber: ashley.Feb 11 2019, 10:56 AM
lcawte triaged this task as Normal priority.Feb 11 2019, 11:41 PM
lcawte moved this task from Backlog to ArticleRatings (ARE) on the Brickimedia board.
ashley closed this task as Resolved.Mar 1 2019, 11:31 AM
ashley assigned this task to lcawte.

This bug was caused by this changeset, as it de facto bumped up the MediaWiki version required to 1.33/git master, whereas Brickipedia was and is currently running 1.31. After we rolled back to an earlier version that did not include that change, page moves are working again.