Page MenuHomePhabricator

LDAP nda access for afandian2 and toddleroux
Closed, ResolvedPublic

Description

Members of my research team @Afandian and @toddleroux were recently granted data access (T209298) for research purposes. I would like them to be able to use the SWAP environment for data analysis. According to the SWAP documentation, membership in LDAP/nda is required.

Information about my two collaborators below:

Wikitech: User:Joe Wass
Shell username: afandian2

Wikitech: User:Toddleroux
Shell username: toddleroux

Thank you!

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 25 2019, 9:03 PM

Hi @RyanSteinberg could you confirm whether the 2 users are WMF employees or contractors? I see in LDAP they don't appear to have @wikimedia.org email addresses but i also can't see them on the NDA sheet for volunteers.

@RStallman-legalteam Do we have NDAs on file for afandian2 and toddleroux ?

Thank you for your help, @Dzahn. Like me, these two users are both formal collaborators and should already have NDAs on file as per T209298. Again, thank you for your help.

Dzahn added a comment.Feb 6 2019, 6:50 PM

@RyanSteinberg Yea, i saw that ticket and how it says "(This can be checked by Operations via the NDA tracking sheet & is included in all WMF Staff/Contractor hiring.)" so i looked in that tracking sheet and i could not find them, hence my follow-up comments.

Dzahn added a comment.Feb 6 2019, 6:52 PM

@RStallman-legalteam Is a formal collaborator a contractor?

Hi @Dzahn, we have a second tab on that spreadsheet with the formal research collaborations and we have both MOUs and NDAs for Todd Leroux and I believe Afandian2 is Joe Wass. If that's correct, they are both covered. Thanks!

Dzahn added a comment.Feb 6 2019, 7:07 PM

Hey @RStallman-legalteam Thanks a lot, this explains it all, i did not see the second tab and i can confirm they are there. Also https://github.com/afandian confirms Afandian is Joe Wass.

Going ahead!

Mentioned in SAL (#wikimedia-operations) [2019-02-06T19:09:50Z] <mutante> LDAP - adding afandian2 and toddleroux to nda (T214727)

Dzahn closed this task as Resolved.Feb 6 2019, 7:11 PM
Dzahn claimed this task.

@RyanSteinberg Done! They have been added and things should work for them now. Since they are already shell users no code change was needed.

Excellent! Thank you, @Dzahn. I think this ticket can be closed.

@Afandian and @toddleroux, please try to access SWAP when you get a chance.