Page MenuHomePhabricator

Wrong error message when installing with postgres as DB-Backend
Closed, ResolvedPublic

Description

Author: rumayer

Description:
When installing mediawiki with postgres as DB-Backend, the function getServerVersion() (in file /usr/share/mediawiki/includes/db/DatabasePostgres.php line 1073) reports any failure in connecting to the DB as a wrong Postgres version.


Version: 1.14.x
Severity: enhancement

Details

Reference
bz19479

Related Objects

View Standalone Graph
This task is connected to more than 200 other tasks. Only direct parents and subtasks are shown here. Use View Standalone Graph to show more of the graph.
StatusSubtypeAssignedTask
InvalidNone
ResolvedNone

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 21 2014, 10:41 PM
bzimport set Reference to bz19479.
bzimport added a subscriber: Unknown Object (MLST).
IAlex added a comment.Jul 21 2009, 9:52 AM
  • This bug has been marked as a duplicate of bug 16937 ***

overlordq wrote:

Not the same bug, this error results in a failed database connection not stopping the installation process when then tries to call getServerVersion on an invalid Database object.

overlordq wrote:

Make config return error if cannot connect as wikiuser

Patch to config

Attached:

IAlex added a comment.Jul 26 2009, 8:09 PM

fixed in r53786.

Jdforrester-WMF added a subscriber: Jdforrester-WMF.

Migrating from the old tracking task to a tag for PostgreSQL-related tasks.