Page MenuHomePhabricator

Gerrit loading slowly
Closed, ResolvedPublic

Description

Hi, gerrit is loading slowly (and also happens to other users too)

Event Timeline

Paladox created this task.Jan 31 2019, 1:47 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 31 2019, 1:47 AM
Paladox triaged this task as Unbreak Now! priority.Jan 31 2019, 1:47 AM
Restricted Application added subscribers: Liuxinyu970226, TerraCodes. · View Herald TranscriptJan 31 2019, 1:47 AM
AntiCompositeNumber renamed this task from Gerrit losing slowly to Gerrit loading slowly.Jan 31 2019, 1:51 AM

I get intermittent plugin failed to load errors, as well as this in console:

Thu Jan 31 01:49:32 GMT+000 2019 Class$82
SEVERE: TypeError: a is null
Class$S43: TypeError: a is null
	at Unknown.TP(https://gerrit.wikimedia.org/r/#/c/mediawiki/core/+/449626 line 9 > scriptElement)
	at Unknown.WP(https://gerrit.wikimedia.org/r/#/c/mediawiki/core/+/449626 line 9 > scriptElement)
	at Unknown._loadedGwt(https://gerrit.wikimedia.org/r/#/c/mediawiki/core/+/449626 line 9 > scriptElement)
	at Unknown.hb(https://gerrit.wikimedia.org/r/#/c/mediawiki/core/+/449626 line 9 > scriptElement)
	at Unknown.Zl(https://gerrit.wikimedia.org/r/#/c/mediawiki/core/+/449626 line 9 > scriptElement)
	at Unknown.g(https://gerrit.wikimedia.org/r/#/c/mediawiki/core/+/449626 line 9 > scriptElement)
	at Unknown.Kc(https://gerrit.wikimedia.org/r/#/c/mediawiki/core/+/449626 line 9 > scriptElement)
	at Unknown.Nc(https://gerrit.wikimedia.org/r/#/c/mediawiki/core/+/449626 line 9 > scriptElement)
	at Unknown.Mc/<(https://gerrit.wikimedia.org/r/#/c/mediawiki/core/+/449626 line 9 > scriptElement)
	at Unknown.Ql(https://gerrit.wikimedia.org/r/#/c/mediawiki/core/+/449626 line 9 > scriptElement)
	at Unknown.anonymous(zuul-0.js)
	at Unknown.m(https://gerrit.wikimedia.org/r/plugins/zuul/static/zuul/zuul.nocache.js)
	at Unknown.onScriptDownloaded/<(https://gerrit.wikimedia.org/r/plugins/zuul/static/zuul/zuul.nocache.js)
	at Unknown.l(https://gerrit.wikimedia.org/r/plugins/zuul/static/zuul/zuul.nocache.js)
	at Unknown.onScriptDownloaded(https://gerrit.wikimedia.org/r/plugins/zuul/static/zuul/zuul.nocache.js)
	at Unknown.anonymous(https://gerrit.wikimedia.org/r/plugins/zuul/static/zuul/7A8CE325BE0EF83E12E6713A5F2B6F37.cache.js)
	at Unknown.anonymous(Unknown)
zuul-0.js:1:6047
TypeError: a is null

Mentioned in SAL (#wikimedia-operations) [2019-01-31T02:01:55Z] <gtirloni> T215004 restarted gerrit (using 1200% cpu, 71% mem)

It seems the issue is gone after a reboot. I didn't see anything special in /var/log/gerrit/error_log.

Thanks for reporting this.

GTirloni closed this task as Resolved.Jan 31 2019, 2:08 AM
GTirloni claimed this task.
GTirloni lowered the priority of this task from Unbreak Now! to High.